0

I noticed yesterday that the nightlight in Ubuntu has stopped working, it's turned on in the settings. nightlight settings

I've also checked dconf-editor, it is turned on in there as well.

I'm running Ubuntu 18.04 with proprietary Nvidia drivers, they're running the latest update available through the repository 410.

nvidia drivers

Any advice is appreciated

1
  • 1
    It could be a bug with the night light control itself. This is only a suggestion though and I know it is working fine for me since I upgraded to 410.66 drivers yesterday and my "night light" was still working OK, but I use a program called Redshift. askubuntu.com/a/951469/231142 – Terrance Oct 19 '18 at 17:45
2

It might have been because you would have changed the "Scheduled Timings" in your Night Light settings and it seems like it doesn't work. You can go change the timings manually and then check.

Also, if you find it a little bothersome to turn it ON & OFF from the settings through the mouse, you can simply make a keyboard shortcut to Toggle Night Light on and Off very easily.

To make things easier, I've written a shellscript to do just that. It works well, and I always use that shortcut to Toggle. Anyone can set it up too! It's easy !! Check this Link for more information : Simplified-Tasks-with-Shell-scripts

1
  • Thanks if I run into this again I'll check this out! – Hugo Sep 24 '19 at 20:12
1

Well, I fixed it. I installed redshift like @Terrance suggested, but it didn't work because it needed location services, which I had disabled.

So I turned those on and immediately the screen yellowed. I assumed that was Redshift working so I've uninstalled it, and turned the Nightlight on and off but it still works...

So, either turning on location services, or installing and then uninstalling Redshift worked... I've now turned location services off again but it's still working.

1
  • 1
    Would you mind adding a little more detail to your answer as while it pointed me in the right direction, I had to do another search to find where location services is turned on and off (inside the privacy settings!). Thanks – Daniel Worthington-Bodart Sep 24 '19 at 5:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.