4

To better describe the above problem, whenever I start up my Ubuntu/Windows 10 Machine and select Ubuntu, whenever the machine tries to start the GNOME Desktop Environment, it says it started it successfully. however, I never get a graphical desktop environment to use. I can fix this by logging into tty3 and typing gnome-session but I don't really want to do that as, for some reason, that skips login. Can anyone help?

4

As its name suggests lightdm is a more lightweight login display manager than gdm3. Switch the login display manager from gdm3 to lightdm. Switching from gdm3 to lightdm will still allow you to login to the GNOME desktop environment as usual.

sudo apt install lightdm  
sudo dpkg-reconfigure lightdm   
sudo reboot  

sudo dpkg-reconfigure lightdm will open up a new window allowing you to select lightdm as the default login display manager. Use the arrow keys to select lightdm and press the Tab key to put the focus on <OK> and press Enter. Then reboot by running this command: sudo reboot

  • Instead of changing DM's, I'd first try editing /etc/gdm3/custom.conf and un-commenting #WaylandEnable=false to disable wayland. – heynnema Dec 16 '18 at 18:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.