0

This question already has an answer here:

I have a blank screen problem on ubuntu 16.04 start up screen. Initially I was repairing my hard disk with fsck /dev/sda1 from this post.

In trying solve the black/blank screen problem on startup, I am following instructions from:

Ubuntu 16.04 [gnome desktop] boots into a blank screen with a cursor on it.

...to use:

chmod 777 /
shutdown -r

etc.

in the 'root terminal' of recovery mode, but it only allows 'read only'. How can I get it into the 'write mode' for this?

Following the method from:

How do I change file system in recovery mode to read-write mode?

It allowed chmod 777 / but would not accept shutdown -r

marked as duplicate by pLumo, Eric Carvalho, waltinator, Charles Green, Thomas Oct 26 '18 at 12:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    The command you want to apply will fully havoc your system. You were lucky that the drive was mounted read-only. – vanadium Oct 19 '18 at 14:56
  • @vanadium - how do you suggest I proceed to fix it? – Brendan Darrer Oct 19 '18 at 15:02
  • 1
    This post is exactly why it was mounted read-only in the first place. Can you try running sudo mount -o remount,rw /? – Lewis Smith Oct 19 '18 at 15:06
  • 1
    Command is not as bad as I first thought because it is not recursive. However, chmod 755 should be enough. You may edit your question, because apparently you are not asking (anymore) about making your file system writable in the recovery prompt. – vanadium Oct 19 '18 at 16:40
1

The issue was solved by booting from a USB flash drive containing ubuntu 16.04 operating system on it (via entering BIOS and to choose USB drive option). And accessing the hard drive from the USB drive. The issue came from an incomplete update of 16.04.

From there I followed:

How to fix black screen after login in Ubuntu 14.04?

to complete the update with:

sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade -f
  • Feel free to accept your own answer. – vanadium Oct 21 '18 at 5:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.