2

I did not have any problems with sound for a long while with my Ubuntu 18.04 LTS installation on Dell Precision 5520. However, recently the sound began disappearing with only the dummy output being shown. Rebooting helped. After trying other solutions, I reinstalled alsa and pulseaudio, at which point even rebooting stopped helping.

The file /proc/asound/cards does not have any cards listed. Interestingly, after running sudo alsa force-reload, this file ceases to exist.

Here is the output of lspci -v | grep -A7 -i "audio":

Fri Oct 19 04:49:40 ~$ lspci -v | grep -A7 -i "audio"
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31) (prog-if 80)
    Subsystem: Dell CM238 HD Audio Controller
    Flags: bus master, fast devsel, latency 32, IRQ 142
    Memory at edd28000 (64-bit, non-prefetchable) [size=16K]
    Memory at edd00000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

I would very much appreciate a direction in fixing the issue.

UPDATE After a day of not using the laptop, I turned it on and it showed Speakers -- Built-in Audio. The contents of /proc/asound/cards:

0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xedd28000 irq 142

However there was no sound. Testing sound from settings did not work. I ran alsamixer and put all volumes to max. Still no luck in the settings. I ran pulseaudio -k && sudo alsa force-reload. Still no luck in the settings. But then I tried playing a video and there was sound! So, I don't know whether the running the last command was necessary.

What could happen during the day of the laptop being powered off? How do I make sure that the issue does not come back?

1
  • facing similar issue, if any solution found please let us know anyone ;) – Shaze Oct 19 '18 at 14:04
4

This also happened to me, and I followed these instructions, and now it works

1) Remove the ALSA packages.

sudo apt-get --purge remove linux-sound-base alsa-base alsa-utils

2) Reinstall the same packages.

sudo apt-get install linux-sound-base alsa-base alsa-utils

3) Install further audio addon packages

sudo apt-get install dkms build-essential linux-headers-`uname -r` alsa-base alsa-firmware-loaders alsa-oss alsa-source alsa-tools alsa-tools-gui alsa-utils alsamixergui

4) Be sure to add the user to group audio

sudo usermod -a -G audio [user_name]

5) reboot

sudo reboot

1
  • This worked for me. Thanks! – called2voyage Jul 19 '20 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.