14

How do you disable the screensaver/powersave function in Ubuntu 18.04?

In Ubuntu 16, you disabled the screensaver in two steps:

  1. First, opening the screensaver gui and selecting "none". But this alone didn't stop the monitor from blanking.
  2. The X server had its own powersave feature that would turn off monitor output when nothing on the screen changed. To disable that, you had to run xset s off.

In Xubuntu 18.04, the second part no longer works. Even though I've run xset s off, my monitor output still blanks if nothing changes after a few minutes. How do I fix that?

I'm running the XFCE desktop, with the xubuntu-desktop package, if that matters.

  • Which screensaver you are using? light-locker maybe? If you have xscreensaver installed, it may interfere display power management. IIRC you can configure light-locker via settings of xfce4-power-manager. – jarno Jul 13 at 8:30
7

Since you're running Xfce, you could try changing the settings of the Xfce Power Manager.

Find Power Manager in the Applications menu or run xfce4-power-manager -c from the terminal. Then you can change the settings in the Display tab.

If Display Power Management is turned ON, then the Power Manager should be in control instead of X11. You should then be able to prevent blank/sleep/power off by setting the appropriate sliders to Never.

| improve this answer | |
0

Try xset s off -dpms.

Source: https://bbs.archlinux.org/viewtopic.php?id=122825

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.