1

Today I did an upgrade from Ubuntu 18.04 LTS to 18.10. The update ran without any error message. After the update the sound settings just show "dummy output".

$ pacmd list-cards
2 card(s) available.
index: 0
name: <alsa_card.pci-0000_01_00.1>
driver: <module-alsa-card.c>
owner module: 7
properties:
    alsa.card = "2"
    alsa.card_name = "HDA NVidia"
    alsa.long_card_name = "HDA NVidia at 0xef080000 irq 17"
    alsa.driver_name = "snd_hda_intel"
    device.bus_path = "pci-0000:01:00.1"
    sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card2"
    device.bus = "pci"
    device.vendor.id = "10de"
    device.vendor.name = "NVIDIA Corporation"
    device.product.id = "0e1b"
    device.product.name = "GK107 HDMI Audio Controller"
    device.string = "2"
    device.description = "GK107 HDMI Audio Controller"
    module-udev-detect.discovered = "1"
    device.icon_name = "audio-card-pci"
profiles:
    output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: no)
    output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 800, available: no)
    output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 800, available: no)
    output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5700, available: no)
    output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 600, available: no)
    output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 600, available: no)
    off: Off (priority 0, available: unknown)
active profile: <off>
ports:
    hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
        properties:
            device.icon_name = "video-display"
    hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
        properties:
            device.icon_name = "video-display"
index: 1
name: <alsa_card.usb-Trust_Webcam_Trust_Webcam_Trust_Webcam-02>
driver: <module-alsa-card.c>
owner module: 8
properties:
    alsa.card = "1"
    alsa.card_name = "Trust Webcam"
    alsa.long_card_name = "Trust Webcam Trust Webcam at usb-0000:00:14.0-3, high speed"
    alsa.driver_name = "snd_usb_audio"
    device.bus_path = "pci-0000:00:14.0-usb-0:3:1.2"
    sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb3/3-3/3-3:1.2/sound/card1"
    udev.id = "usb-Trust_Webcam_Trust_Webcam_Trust_Webcam-02"
    device.bus = "usb"
    device.vendor.id = "0c45"
    device.vendor.name = "Microdia"
    device.product.id = "6340"
    device.product.name = "Camera"
    device.serial = "Trust_Webcam_Trust_Webcam_Trust_Webcam"
    device.form_factor = "webcam"
    device.string = "1"
    device.description = "Camera"
    module-udev-detect.discovered = "1"
    device.icon_name = "camera-web-usb"
profiles:
    input:analog-mono: Analog Mono Input (priority 7, available: unknown)
    off: Off (priority 0, available: unknown)
active profile: <input:analog-mono>
sources:
    alsa_input.usb-Trust_Webcam_Trust_Webcam_Trust_Webcam-02.analog-mono/#0: Camera Analog Mono
ports:
    analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: unknown)
        properties:
            device.icon_name = "audio-input-microphone"

lspci

$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)

destailed lspci

$ sudo lspci -nnk |  grep -A2 Audio
00:1b.0 Audio device [0403]: Intel Corporation 8 Series/C220 Series 
  Chipset High Definition Audio Controller [8086:8c20] (rev 05)
  Subsystem: Hewlett-Packard Company 8 Series/C220 Series Chipset High Definition Audio Controller [103c:1905]
  Kernel driver in use: snd_hda_intel
  Kernel modules: snd_hda_intel
--
01:00.1 Audio device [0403]: NVIDIA Corporation GK107 HDMI Audio 
Controller [10de:0e1b] (rev a1)
  Subsystem: Hewlett-Packard Company GK107 HDMI Audio Controller [103c:094b]
  Kernel driver in use: snd_hda_intel
  Kernel modules: snd_hda_intel

Screenshot Sound settings Screenshot Additional drivers

5

I had the same problem. Found out on another site that my issue was solved by uninstalling timidity. After a reboot I have sound again.

  • That solved the problem for me without even having to reboot. Just run sudo apt-get remove timidity and sound started to play immediately – raffamaiden Oct 23 '18 at 21:37
  • Very weird, but thanks! – Charles Green Nov 1 '18 at 20:09
0

Having the same issue, and dns lookup as well (almost having no internet connection at all, it switches off in a random-long very first minutes after booting, quite annoying situation)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.