After I updated to Ubuntu 18.10 my sound device isn't recognized anymore. Only a dummy device is shown.

I have an onboard Intel device:

lspci -nnk | grep -A2 Audio
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
    Subsystem: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller [8086:2036]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

The command pacmd list-cards does not show any devices:

:~$ pacmd list-cards
0 card(s) available.

This message in /var/log/syslog might have to do something with the problem:

Oct 19 21:02:06 MyComputerName pulseaudio[14331]: E: [pulseaudio] 
backend-ofono.c: Failed to register as a handsfree audio agent with 
ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono 
was not provided by any .service files

Does anybody have the same issue? How can I fix this?



sudo apt purge timidity-daemon 


  • I had the same problem on upgrade to Ubuntu 18.10 -- and thank you @abu_bua -- removing timidity-daemon fixed it! I had scoured the net and deleted pulse configs, reloaded alsa -- tried everything... How did you figure this out and what is it about timidity-daemon was causing the problem? – Michael Back Oct 25 '18 at 12:29
  • @MichaelBack I think it's that timidity is opening the sound device before pulseaudio can start, and blocking pulseaudio from getting it. As soon as timidity exits, the devices pop up in pulse. A previous release must have had a different order of operations, or the two things must have been more willing to share. – hobbs Nov 15 '18 at 2:45
  • My problem is similar; but, I'm using AMD instead of Intel. This solution did not solve my problem, though. – TheGeeko61 Nov 25 '18 at 16:52
  • Solved it for me too. Incredible. – Riccardo Orlando Jan 11 at 15:48

I turned out that the cause where old pulseaudio config files. I did remove them with:

sudo apt purge alsa-base pulseaudio

This will cause some dependencies to be purged as well. So the easiest way to reinstall everything is to do:

sudo apt install ubuntu-gnome-desktop

But this might bring you some packages back, you had intentionally removed before. So keep track of what is being installed.

Another way to reinstall what was removed is to simply copy the list of uninstalled packages from the terminal:

The following packages will be REMOVED:
   alsa-base* indicator-sound* libcanberra-pulse* paprefs* pulseaudio* 
   pulseaudio-equalizer* pulseaudio-esound-compat* pulseaudio-module-bluetooth* 
   pulseaudio-module-gsettings* pulseaudio-module-raop*
   pulseaudio-module-zeroconf* ubuntu-desktop* ubuntu-gnome-desktop*

So for me this was:

sudo apt install alsa-base indicator-sound libcanberra-pulse paprefs\
pulseaudio pulseaudio-equalizer pulseaudio-esound-compat\
pulseaudio-module-bluetooth pulseaudio-module-gsettings\
pulseaudio-module-raop pulseaudio-module-zeroconf ubuntu-desktop\

After you have reinstalled everything you shout do:

sudo alsa force-reload

After this the sound device should work again.

  • This did not work for a clean install of Ubuntu 18.10 on a Lenovo Thinkpad P72. – Lexible Jan 14 at 5:35
  • This failed on an 18.10 upgrade on a Lenovo G50. – TheGeeko61 Jan 20 at 0:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.