10

After I updated to Ubuntu 18.10 my sound device isn't recognized anymore. Only a dummy device is shown.

I have an onboard Intel device:

lspci -nnk | grep -A2 Audio
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
    Subsystem: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller [8086:2036]
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

The command pacmd list-cards does not show any devices:

:~$ pacmd list-cards
0 card(s) available.

This message in /var/log/syslog might have to do something with the problem:

Oct 19 21:02:06 MyComputerName pulseaudio[14331]: E: [pulseaudio] 
backend-ofono.c: Failed to register as a handsfree audio agent with 
ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono 
was not provided by any .service files

Does anybody have the same issue? How can I fix this?

17

Try

sudo apt purge timidity-daemon 

and

reboot
| improve this answer | |
  • I had the same problem on upgrade to Ubuntu 18.10 -- and thank you @abu_bua -- removing timidity-daemon fixed it! I had scoured the net and deleted pulse configs, reloaded alsa -- tried everything... How did you figure this out and what is it about timidity-daemon was causing the problem? – Michael Back Oct 25 '18 at 12:29
  • @MichaelBack I think it's that timidity is opening the sound device before pulseaudio can start, and blocking pulseaudio from getting it. As soon as timidity exits, the devices pop up in pulse. A previous release must have had a different order of operations, or the two things must have been more willing to share. – hobbs Nov 15 '18 at 2:45
  • My problem is similar; but, I'm using AMD instead of Intel. This solution did not solve my problem, though. – TheGeeko61 Nov 25 '18 at 16:52
  • 1
    Solved it for me too. Incredible. – Riccardo Orlando Jan 11 '19 at 15:48
  • Did not work for me – aez Jul 18 '19 at 1:48
3

I turned out that the cause where old pulseaudio config files. I did remove them with:

sudo apt purge alsa-base pulseaudio

This will cause some dependencies to be purged as well. So the easiest way to reinstall everything is to do:

sudo apt install ubuntu-gnome-desktop

But this might bring you some packages back, you had intentionally removed before. So keep track of what is being installed.

Another way to reinstall what was removed is to simply copy the list of uninstalled packages from the terminal:

The following packages will be REMOVED:
   alsa-base* indicator-sound* libcanberra-pulse* paprefs* pulseaudio* 
   pulseaudio-equalizer* pulseaudio-esound-compat* pulseaudio-module-bluetooth* 
   pulseaudio-module-gsettings* pulseaudio-module-raop*
   pulseaudio-module-zeroconf* ubuntu-desktop* ubuntu-gnome-desktop*

So for me this was:

sudo apt install alsa-base indicator-sound libcanberra-pulse paprefs\
pulseaudio pulseaudio-equalizer pulseaudio-esound-compat\
pulseaudio-module-bluetooth pulseaudio-module-gsettings\
pulseaudio-module-raop pulseaudio-module-zeroconf ubuntu-desktop\
ubuntu-gnome-desktop

After you have reinstalled everything you shout do:

sudo alsa force-reload

After this the sound device should work again.

| improve this answer | |
  • This did not work for a clean install of Ubuntu 18.10 on a Lenovo Thinkpad P72. – Lexible Jan 14 '19 at 5:35
  • This failed on an 18.10 upgrade on a Lenovo G50. – TheGeeko61 Jan 20 '19 at 0:38
  • 1
    I would recommend this instead: sudo apt install --reinstall -o Dpkg::Options::="--force-confask,confnew,confmiss" pulseaudio alsa-base It will reinstall configuration files without having to uninstall and afterwards manually install dependent packages. – gustavwiz Apr 13 '19 at 14:51
0

this is what I did that got my 18.04 to recognize audio again:

sudo apt install --reinstall alsa-base pulseaudio
sudo alsa force-reload

your mileage may vary. but it worked for me. (tm)

| improve this answer | |
0

Install pavucontrol using

sudo apt-get install pavucontrol

After the installation, open it by typing the command pavcontrol in terminal and select the output devices.

| improve this answer | |
  • after install open it by typing the command pavcontrol in terminal and select the output devices – Rajesh Krishna Jul 4 '19 at 8:34
  • 2
    Hey Rajesh, welcome to Ask Ubuntu. Comments are used for asking for clarifications or suggestions for improving the answer. Please avoid adding half answers in comments. – Kulfy Jul 4 '19 at 8:56
  • Its pavucontrol not pavcontrol. – R. Gurung Dec 7 '19 at 9:40
0

I just had a similar but slightly different experience after upgrading from 19.04 to 19.10. Everything was fine until I plugged my laptop into a DisplayLink hub then I lost all sound. I saw on another forum people talking about losing sound after plugging into an HDMI screen so this is similar.

What I had was that all my devices showed up but I couldn't get any sound out of them. In the sound control panel I could choose a USB headset but when I click on test, there are no speakers to click on to perform the test. The simple fix for me was just to kill and restart pulseaudio

pulseaudio --k

pulseaudio --start

After that everything came back to life.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.