1

I followed this tutorial to create a virtual machine with ubuntu: https://linus.nci.nih.gov/bdge/installUbuntu.html
The last section in the tutorial is about how to use shared folders. I did everything that is described there and sudo adduser username vboxsf worked just fine and my user has been added to the sharefolder. But now on my guest machine I can't find the shared folder. In the tutorial they say, it would now be created in computer->filesystem->media->sf_sharefoldername but a systemwide search for "sf_" didn't give any results. Also the path computer->filesystem doesn't exist. Instead I can access computer->media. Does anyone know what I'm doing wrong/where the folder is and what it's name will be?

I don't think it's a duplicate of the question you linked, @N0rbert. As described in the tutorial that I linked, I did use the automount option of virtualbox

Shared folder settings: enter image description here

6
  • @N0rbert Not a duplicate, I already found that question before. Doesn't solve my problem. I don't have problems accessing the folder, there just is no folder. Also: see my edit to the question. – Max Oct 19 '18 at 8:49
  • I think it exists. Did you tried to run sudo mount -t vboxsf windows_share /media/windows_share (where windows_share is folder name)? What is your host system? Please add screenshot of shared folders tab (similar to one from the article) to the question. – N0rbert Oct 19 '18 at 8:53
  • @N0rbert that command resulted in "mounting failed with the error: No such file or directory". I'll edit screenshots, wait a moment – Max Oct 19 '18 at 8:55
  • So you should change the command above to something like sudo mount -t vboxsf share /mnt (the /mnt is mount-point, it should exist). – N0rbert Oct 19 '18 at 9:04
  • @N0rbert ok, well this works, thanks. But why is this /media/share not created? And now I can only create files on mnt using sudo, how can I change the permission there so I can also drag&drop files into the sharefolder? – Max Oct 19 '18 at 9:09
1

I understood what was changed. On modern Ubuntu versions automatically created mount-points are in unsername subfolder of /media - that is /media/username (instead of simple /media).

So if you have installed VirtualBox guest-additions, setup auto-mount

AutoMount share

and reboot the guest, then it should be shown as sf_mountpoint on the desktop (GNOME - left, MATE - right):

GNOME desktop or MATE desktop

and in the filemanager

mountpoint in Nautilus or mountpint in Caja


The link to official documentation - is 4 Guest Additions → 4.3 Shared folders → 4.3.2 Automatic mounting.

6
  • Well, the folder was just not created. Also not in /media/username, I checked that before asking the question. I had to manually create and mount it now, I guess the automount option just didn't work at all. The only thing that was in the /media/username folder, was the .iso image of guest-additions. Except for that this is a good answer. – Max Oct 19 '18 at 9:31
  • Looks strange. I have tested this method on Ubuntu MATE 16.04 LTS amd64 host with VirtualBox 5.1.38 and Ubuntu 18.04 LTS guests (GNOME and MATE). Both have created mountpoints after enabling automount and rebooting the guest. – N0rbert Oct 19 '18 at 9:35
  • Don't know why It was not created, but I tried rebooting and it still didn't happen. My host system is Kubuntu 16.04.5 LTS with Dolphin (as far as I understood Dolphin, Gnome and Mate are all filemanagers?!) – Max Oct 19 '18 at 9:39
  • K in Kubuntu means KDE. KDE is a desktop environment (DE) with Dolphin file-manager. GNOME and MATE are other/alternative DEs with respectively Nautilus and Caja as file-managers :) The host DE should not cause guest problems. – N0rbert Oct 19 '18 at 9:41
  • Thanks for the explanation. All these names are very confusing when you first enter linux coming from mac where there is only one strict chronological order of versions, and nothing can be altered. – Max Oct 19 '18 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.