46

A few days ago, I started getting the following error when performing apt-get update:

E: Repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease' changed its 'Label' value from 'Oracle Java (JDK) 8 / 9 Installer PPA' to 'Oracle Java (JDK) 8 Installer PPA' 
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

According to WebUpd8, that, that, that, and that page, I don't seem to need a key for this (anymore).

If I remove the key

/etc/apt/trusted.gpg.d/webupd8team_ubuntu_java.gpg
pub   rsa1024 2010-05-04 [SC]
      7B2C 3B08 89BF 5709 A105  D03A C251 8248 EEA1 4886
uid   [ unknown] Launchpad VLC

with apt-key del, I (obviously) get

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY C2518248EEA14886

Thanks for any further help with this.

  • This was part of my problem, but before I saw this message I was getting Failed to fetch http://ppa.launchpad.net/webupd8team/java/ubuntu/pool/main/o/oracle-java8-installer/oracle-java8-installer_8u181-1~webupd8~1_all.deb 404 Not Found. Michał Knapiński's answer here solved both of my problems. It fixed the 404 and also asked my to accept the label change. – Stephen Ostermiller Oct 29 '18 at 15:13
69

This command should do the trick:

sudo apt-get --allow-releaseinfo-change update
sudo apt-get update

Have a nice day

  • 6
    Sorry, didn't do it for me. I'm getting the same error again. – Mario Oct 19 '18 at 8:47
  • 6
    It worked for me: ubuntu 18.04 – Mario Stefanutti Oct 19 '18 at 22:36
  • 2
    It worked for me too. You'll still get the first msg about the label change but not the second "this must be accepted explicitly" message. – EricS Oct 23 '18 at 23:03
  • 13
    run "sudo apt-get update" after running the above command. - works for me. ubuntu 18.04 – Drew Nov 3 '18 at 4:35
  • 2
    @Drew, running sudo apt-get update afterwards was crucial to fixing the issue for me. Thanks. – Austin Dean Dec 29 '18 at 16:52
18

Software and updates -> other software -> remove webupd8team PPA.

sudo add-apt-repository ppa:webupd8team/java

sudo apt-get update

worked for me.

  • 4
    Thx, deleting the webupd8 files in /etc/apt/sources.list.d helped. – Mario Oct 19 '18 at 8:56
9

Steps that worked for me on Mint 19:

  1. remove the webupd8 ppa from sources.list.d

    cd /etc/apt/sources.list.d
    rm webupd8team-java-bionic.list
    
  2. use the command that our friend above posted for us:

    sudo apt-get --allow-releaseinfo-change update
    
  3. then re-add the ppa again and update it.

7

I think you all are missing the underlying problem.... The PPA no longer works:

root@ced-looker1:/etc/apt/sources.list.d# add-apt-repository ppa:webupd8team/java The Oracle JDK License has changed for releases starting April 16, 2019.

The new Oracle Technology Network License Agreement for Oracle Java SE is substantially different from prior Oracle JDK licenses. The new license permits certain uses, such as personal use and development use, at no cost -- but other uses authorized under prior Oracle JDK licenses may no longer be available. Please review the terms carefully before downloading and using this product. An FAQ is available here: https://www.oracle.com/technetwork/java/javase/overview/oracle-jdk-faqs.html

Oracle Java downloads now require logging in to an Oracle account to download Java updates, like the latest Oracle Java 8u211 / Java SE 8u212. Because of this I cannot update the PPA with the latest Java (and the old links were broken by Oracle). For this reason, THIS PPA IS DISCONTINUED (unless I find some way around this limitation).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.