4

To upgrade from 18.04 to 18.10 I executed the following commands: "sudo apt-get dist-upgrade" and "sudo do-release-upgrade"

Upgrade proceeded normally until the system reached the reboot phase. Following reboot the normal maroon dot progress screen was displayed for a few seconds. This was replaced with a black screen with the message "Main-Linux clean 574402/3567072 files, 7146011/14350592 blocks". And there it stopped with no further changes evident.

Ctrl-F1 took me to the normal console log in. I could log in and found everything was running normally. Disks were all present, active and with plenty of free space. Ctrl-F7 took me back to the black screen with the single message at the top of the screen.

I tried booting with the previous kernel but got the same result.

I have a spare 18.04 Linux on another partition. After booting into it a cursory look at my main system showed nothing untoward.

I have successfully upgraded Ubuntu for more than ten years and this is the first problem I have experienced.

Where do I go from here? How do I fix the problem?

Edit:

After booting into my spare Ubuntu 18.04 on another partition I used the Disks program to do file system checks on the main partitions. This reported that the file systems were clean. I then tried to reboot into 18.10 but again got the same problem, described above.

I have checked the SMART status of the SSD and it reports all is OK after self-test. The processor is Intel Pentium(R) CPU G4400 @ 3.30GHz × 2 and the GPU is Intel HD Graphics 510 (Skylake GT1)

Update:

After logging in at the console(Alt-Ctrl-F1) I can start the GUI by entering startx. For some reason the GUI subsystem fails to start automatically, as it did before.

  • 1
    Hmm, voting down a question is really not useful without a comment explaining the reason. I have a severe job-stopper of a problem. I have explained it clearly(I hope). I don't know how to fix the problem so I have come to the one place where I should be able to get help. – labnut Oct 19 '18 at 8:19
  • 1
    Your problem description is indeed relatively clear and should not be downvoted without comment (I voted up to balance, though your question does not deserve that either ;-)). Though please add: GPU make and model, Type of storage (HDD or SSD etc.) and if you checked the SMART status of the drive askubuntu.com/questions/528072/… or something else with DISCS. . – Bruni Oct 19 '18 at 8:54
  • It is an SSD. Yes, I have checked the SMART status and it reports all is OK after self-test. The processor is Intel Pentium(R) CPU G4400 @ 3.30GHz × 2 and the GPU is Intel HD Graphics 510 (Skylake GT1) – labnut Oct 19 '18 at 9:01
0

Do you happen to have nvidia graphic card on that computer? If you so it might be the cause of your problems.

You can try by reinstall it from command line. For me it was this, but you might have an other version.

sudo apt remove nvidia-396
sudo apt install -f nvidia-396

An other cause might be an incomplete update.

  • 2
    No, the graphics chip set is from Intel. – labnut Oct 19 '18 at 8:54
  • The update process seemed to run cleanly through to completion. – labnut Oct 19 '18 at 9:10
  • 18.10 still has nvidia-390 – arved Oct 23 '18 at 7:22
0

Our help is limited by the information you give us so posting your computer specs would help out. However, I ran into this same issue and when I get the black screen I went to recovery mode -> enable networking -> root. Then I ran apt install openssh-server, rebooted, got black screen, ssh'd into my PC and downloaded and installed the latest kernel 4.19rc8 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19-rc8/.

That seemed to fix my issue. Without more information though YMMV.

0

Same issue, black screen after ubnutu update. It was a prompt asking for reboot for changes to take effect. I guess update to 18.04.1, not sure what from, perhaps 18.04, it was automatic.

This worked for me (I spent several hours on this, again):

Disable Fast Boot in UEFI

For me it's del key to enter UEFI

I don't know if this has anything to do with me using encrypted disk (Black screen before any decrypt prompt), but thought I'd mention it.

NOTE: I have now re-enabled Fast Boot and it works again. I don't feel that I have any definitive proof, but better share my results than not.

0

I just did an upgrade on Lubuntu. My symptoms were a blank screen and visible/movable mouse cursor. I could get to my desktop by switching to vt1 (ctrl-alt-F1) and switching back to vt7 (alt-F7). My issue was an xrandr command in .xprofile which worked on the earlier version of Lubuntu, but which hung (not crashed) on the current one. I commented out the that line in .xprofile and all returned to normal.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.