So recently I was able to plug in my headphones to my Ubuntu 18.04 laptop, but now I am not getting any sound. I think it may because I did an apt install of "mono-complete", "xdotool" and "libappindicator3-0.1-cil-dev". I have purged all of these, and it still will not allow me to hear what is going on in my headphones. I am also using ubuntu-unity-desktop instead of the 18.04 default desktop as well.

Yes, I have checked if things are muted, autoremoved and cleaned apt-get, removed /usr/share/pulseaudio/alsa-mixer/paths/*, did 'alsa force-reload', rebooted computer, removed ~/.conf ~/.pulse etc. that is already online.

Here is what /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf looks like (after I tried editting it and rebooting): http://paste.debian.net/1048009/

Here is also what /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones-2.conf looks like after editing and rebooting: http://paste.debian.net/1048010/

I do get a bunch of mentions in the ....paths/analog-output-headphones.conf about "mono". If "mono-complete" package is breaking pulseaudio, then I don't know how to get rid of it. Here is the

I was trying to use RemoteMouse, which required those packages to be installed, if that helps anyone.

2 Answers 2


I had the same problem.

Here is the way that I found which may work for your system, as I have Ubuntu 18.04 with ubuntu-unity-desktop too. Type in your cmd prompt: alsamixer It will show you system sound control, where you can try to play, and adjust around. Try to turn on all the MM bars (which is muted) or switch to other sound cards if you have.

While you are adjusting them, go to Setting>>Sound>>Test Sound, try to test it if it works.

Good luck.


After 3 hours of troubleshooting: Open terminal:

sudo apt-get purge pulseaudio alsa-base
sudo apt-get clean
sudo apt-get autoremove
sudo rm -rf ~/.conf/pulse/
sudo rm -rf ~/.config/pavucontrol.ini
sudo apt-get purge pulseaudio utils
sudo reboot

(wait for reboot, log back in and open terminal)

sudo apt-get install pulseaudio pulseaudio-utils alsa-base ubuntu-desktop ubuntu-unity-desktop
sudo reboot

Not sure if all those steps were necessary, but after 3 hours, I'm fed up with trying minimalist solutions. Hope this helps!

  • Did not succeed in restoring a missing alsamixer when I tried in 18.04
    – 42-
    Nov 8, 2018 at 20:27
  • caution! this answer is harmful. do backups. my problem was "no sound in headphones", and after following this instruction I don't have sound at all (pulse audio shows a Dummy device). Ubuntu 18.10. Feb 15, 2019 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.