1

So, I installed Ubuntu 18.04 with gnome3 and then lured by the prettiness of elementary OS 5.0, I installed that as per the instructions. Now, I have purged all the PPAs as suggested by this or other answers here. However, I still get elementary os screen at the boot and when I see the about in gnome UI.

Cosmetics is not much of a problem for me but when I am trying to upgrade from 18.04 to 18.10, I am not receiving any update when I do sudo do-release-upgrade -d or sudo do-release-upgrade.

How do I completely restore my gnome? or more directly How do I move to 18.10?

Output of dpkg -l | grep -i elementary is

ii  base-files                                      10.1ubuntu2.3+elementary12~ubuntu18.04.1       amd64        Debian base system miscellaneous files
ii  bash                                            4.4.18-2ubuntu1+elementary3~ubuntu5.0.1        amd64        GNU Bourne Again SHell
ii  browser-plugin-evince                           3.28.2-1+elementary2~ubuntu5.0.1               amd64        plugin for web browsers to display documents (PostScript, PDF, …)
ii  desktop-file-utils                              0.23-1ubuntu3.18.04.1+elementary2~ubuntu5.0.1  amd64        Utilities for .desktop files
rc  elementary-default-settings                     5.0-0~304~ubuntu5.0.1                          all          Default settings for elementary OS
rc  elementary-icon-theme                           4.4.0+r2076~ubuntu5.0.1                        all          simple and appealing Tango-styled icon theme
ii  epiphany-browser                                3.28.1-1ubuntu1+elementary20~ubuntu5.0.1       amd64        Intuitive GNOME web browser
ii  epiphany-browser-data                           3.28.1-1ubuntu1+elementary20~ubuntu5.0.1       all          Data files for the GNOME web browser
ii  evince                                          3.28.2-1+elementary2~ubuntu5.0.1               amd64        Document (PostScript, PDF) viewer
ii  evince-common                                   3.28.2-1+elementary2~ubuntu5.0.1               all          Document (PostScript, PDF) viewer - common files
ii  file-roller                                     3.28.0-1ubuntu1+elementary4~ubuntu5.0.1        amd64        archive manager for GNOME
rc  fonts-croscore-config-elementary                5.0-0+33~ubuntu5.0.1                           all          Map open-source Croscore fonts to MS fonts
ii  geoclue-2.0                                     2.4.7-1ubuntu1+elementary2+r2~ubuntu5.0.1      amd64        geoinformation service
ii  gir1.2-evince-3.0:amd64                         3.28.2-1+elementary2~ubuntu5.0.1               amd64        GObject introspection data for the evince libraries
ii  gir1.2-geoclue-2.0:amd64                        2.4.7-1ubuntu1+elementary2+r2~ubuntu5.0.1      amd64        convenience library to interact with geoinformation service (introspection)
ii  gir1.2-gnomebluetooth-1.0:amd64                 3.28.0-2+elementary2~ubuntu5.0.1               amd64        Introspection data for GnomeBluetooth
ii  gir1.2-gtksource-3.0:amd64                      3.24.7-1+elementary5~ubuntu5.0.1               amd64        gir files for the GTK+ syntax highlighting widget
ii  gir1.2-ibus-1.0:amd64                           1.5.17-3ubuntu4+elementary2+r1~ubuntu5.0.1     amd64        Intelligent Input Bus - introspection data
ii  gir1.2-nmgtk-1.0:amd64                          1.8.10-2ubuntu1+elementary2~ubuntu18.04.1      amd64        GObject introspection data for libnm-gtk
ii  gnome-settings-daemon                           3.28.1-0ubuntu1+elementary3~ubuntu5.0.1        amd64        daemon handling the GNOME session settings
ii  gnome-settings-daemon-schemas                   3.28.1-0ubuntu1+elementary3~ubuntu5.0.1        all          Shared schemas for gnome-settings-daemon
ii  ibus                                            1.5.17-3ubuntu4+elementary2+r1~ubuntu5.0.1     amd64        Intelligent Input Bus - core
ii  ibus-gtk:amd64                                  1.5.17-3ubuntu4+elementary2+r1~ubuntu5.0.1     amd64        Intelligent Input Bus - GTK+2 support
ii  ibus-gtk3:amd64                                 1.5.17-3ubuntu4+elementary2+r1~ubuntu5.0.1     amd64        Intelligent Input Bus - GTK+3 support
rc  io.elementary.cerbere                           0.2.4+r70-0+pkg30~ubuntu5.0.1                  amd64        service to relaunch Pantheon shell components
rc  io.elementary.dpms-helper                       1.0+r8+pkg11~ubuntu5.0.1                       all          script and settings for X DPMS
ii  language-selector-common                        0.188.1+elementary4~ubuntu18.04.1              all          Language selector for Ubuntu
ii  language-selector-gnome                         0.188.1+elementary4~ubuntu18.04.1              all          Language selector for Ubuntu
ii  libevdocument3-4:amd64                          3.28.2-1+elementary2~ubuntu5.0.1               amd64        Document (PostScript, PDF) rendering library
ii  libevview3-3:amd64                              3.28.2-1+elementary2~ubuntu5.0.1               amd64        Document (PostScript, PDF) rendering library - Gtk+ widgets
ii  libgeoclue-2-0:amd64                            2.4.7-1ubuntu1+elementary2+r2~ubuntu5.0.1      amd64        convenience library to interact with geoinformation service
ii  libgnome-bluetooth13:amd64                      3.28.0-2+elementary2~ubuntu5.0.1               amd64        GNOME Bluetooth tools - support library
ii  libgtksourceview-3.0-1:amd64                    3.24.7-1+elementary5~ubuntu5.0.1               amd64        shared libraries for the GTK+ syntax highlighting widget
ii  libgtksourceview-3.0-common                     3.24.7-1+elementary5~ubuntu5.0.1               all          common files for the GTK+ syntax highlighting widget
ii  libibus-1.0-5:amd64                             1.5.17-3ubuntu4+elementary2+r1~ubuntu5.0.1     amd64        Intelligent Input Bus - shared library
ii  libibus-1.0-dev:amd64                           1.5.17-3ubuntu4+elementary2+r1~ubuntu5.0.1     amd64        Intelligent Input Bus - development file
ii  libnm-gtk0:amd64                                1.8.10-2ubuntu1+elementary2~ubuntu18.04.1      amd64        library for wireless and mobile dialogs (libnm-glib version)
ii  libnma0:amd64                                   1.8.10-2ubuntu1+elementary2~ubuntu18.04.1      amd64        library for wireless and mobile dialogs (libnm version)
ii  lsb-base                                        9.20170808ubuntu1+elementary4~ubuntu18.04.1    all          Linux Standard Base init script functionality
ii  lsb-release                                     9.20170808ubuntu1+elementary4~ubuntu18.04.1    all          Linux Standard Base version reporting utility
ii  mutter-common                                   3.28.3-2~ubuntu18.04.1+elementary3~ubuntu5.0.1 all          shared files for the Mutter window manager
ii  network-manager-gnome                           1.8.10-2ubuntu1+elementary2~ubuntu18.04.1      amd64        network management framework (GNOME frontend)
rc  plank                                           0.11.4+git20180707.0a842b45-0elementary0.5.1   amd64        Elegant, simple, clean dock
ii  python-apt-common                               1.6.2+elementary6~ubuntu5.0.1                  all          Python interface to libapt-pkg (locales)
ii  python3-apt                                     1.6.2+elementary6~ubuntu5.0.1                  amd64        Python 3 interface to libapt-pkg
ii  python3-cupshelpers                             1.5.11-1ubuntu2+elementary2~ubuntu5.0.1        all          Python utility modules around the CUPS printing system
ii  python3-software-properties                     0.96.24.32.5+elementary7~ubuntu18.04.1         all          manage the repositories that you install software from
ii  software-properties-common                      0.96.24.32.5+elementary7~ubuntu18.04.1         all          manage the repositories that you install software from (common)
ii  software-properties-gtk                         0.96.24.32.5+elementary7~ubuntu18.04.1         all          manage the repositories that you install software from (gtk)
ii  system-config-printer                           1.5.11-1ubuntu2+elementary2~ubuntu5.0.1        all          graphical interface to configure the printing system
ii  system-config-printer-common                    1.5.11-1ubuntu2+elementary2~ubuntu5.0.1        all          backend and the translation files for system-config-printer
ii  system-config-printer-gnome                     1.5.11-1ubuntu2+elementary2~ubuntu5.0.1        all          graphical interface to configure printers (transitional package)
ii  system-config-printer-udev                      1.5.11-1ubuntu2+elementary2~ubuntu5.0.1        amd64        Utilities to detect and configure printers automatically
rc  unattended-upgrades                             1.1ubuntu1.18.04.5+elementary5~ubuntu5.0.1     all          automatic installation of security upgrades
ii  xdg-user-dirs                                   0.17-1ubuntu1+elementary2~ubuntu5.0.1          amd64        tool to manage well known user directories
ii  xdg-user-dirs-gtk                               0.10-2+elementary2~ubuntu5.0.1                 amd64        tool to manage well known user directories (Gtk extension)
  • Hint: Why are you using the '-d' flag? – user535733 Oct 18 '18 at 22:50
  • with or w/o -d flag.. outcome is same – Umang Gupta Oct 18 '18 at 22:53
  • 2
    -d flag shows you the versions which are available but in development stage while the other will show the latest stable update. I believe that you have opted for LTS updates only which means 18.10 won't be delivered to you. You can confirm it from Software and Updates app. Also, have you tried reinstalling or re-configuring GNOME? – Kulfy Oct 19 '18 at 0:07
  • I did uninstall gnome-shell and reinstalled. Also, I have opted for notifying of any new update and not only lts – Umang Gupta Oct 19 '18 at 0:27
  • Try reinstalling ubuntu-gnome-desktop instead of only gnome-shell. Also, it is suggested to stick to LTS unless and until it is required to move to non-LTS. – Kulfy Oct 19 '18 at 8:05
4

It is bad idea do upgrade from LTS to non-LTS version. You will need to wait for 20.04 LTS with all possible stops as 19.04 and 19.10. Consider to stay on 18.04 LTS.

If you have added elementary by PPAs, then you can remove them with commands below:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:elementary-os/daily
sudo ppa-purge ppa:elementary-os/os-patches
sudo ppa-purge ppa:elementary-os/stable
sudo ppa-purge ppa:elementary-os/staging
sudo ppa-purge ppa:elementary-os/testing

then reinstall GNOME Shell with

sudo apt-get install ubuntu-desktop

As we have the output of dpkg -l | grep -i elementary then I can suggest two things:

1. Purge remaining packages with rc state (with remaining config files):

sudo apt-get purge $(dpkg -l | grep -i elementary | grep ^rc | awk '{print $2}')

2. Reinstall packages with elementary versions from current repositories:

sudo apt-get install --reinstall $(dpkg -l | grep -i elementary | grep ^ii | awk '{print $2}')
  • Nope! doesn't work. Purged & reinstalled. Didnt work – Umang Gupta Oct 28 '18 at 19:54
  • 1
    Then please add output of dpkg -l | grep -i elementary to your question. – N0rbert Oct 28 '18 at 19:57
  • Thanks for paying attention to this question. I have updated the question with output and I sort of understand what is happening but how do I get rid of it? – Umang Gupta Oct 28 '18 at 20:01
  • Updated answer. Please carefully follow the last part. – N0rbert Oct 28 '18 at 20:34
  • This ideally works that why I accepted the answer. However, this bricked my OS. As uninstalling lsb related packages led to uninstallation of everything – Umang Gupta Oct 28 '18 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.