Attempts to connect an apple wireless keyboard to ubuntu, via a usb bluetooth adapter fail. I've tried several different keyboards with same result. Using bluetoothctl and all seems to go well until:

>Attempting to connect to 60:FB:42:09:BE:94  "the keyboard"
>[CHG] Device 60:FB:42:09:BE:94 Connected: yes
>[CHG] Device 60:FB:42:09:BE:94 ServicesResolved: yes
>Failed to connect: org.bluez.Error.InProgress
>[CHG] Device 60:FB:42:09:BE:94 ServicesResolved: no
>[CHG] Device 60:FB:42:09:BE:94 Connected: no

Any ideas of what is missing or misconfigured?

UPDATE: In case it might be useful - problem is missing kernel module, hidp, which handles protocol for keyboards, etc. xubuntu was installed w/o any bluetooth devices in the machine so that module wasn't inserted. Adding it to /etc/modules solves the problem. If the bluetooth device is from Apple, you also need to add the hid-apple module.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.