3

I have the Realtek rtl8723be driver on my HP-Pavillion Notebook.

While installing Ubuntu 18.04 LTS through plug-n-play option, I tried the following commands before actual installation:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=2

and the wifi was working just fine.

But after installation alongside Windows 10, somehow the wifi stopped working properly, and now only wifi networks very close to the device appear.

I tried installing realtek software from here on GitHub as mentioned in the README. But still no progress.

I even tried changing ant_sel parameters, then saving them to my /etc/modprobe.d/rtl8723be.conf and then performing a cold boot. But still no progress.

I also tried installing from this branch, but I got errors.

sudo lshw -class network
  *-network                 
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: wlo1
       version: 00
       serial: 70:77:81:bf:a7:b9
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.15.0-36-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:18 ioport:5000(size=256) memory:c6100000-c6103fff
  *-network
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eno1
       version: 0a
       serial: 3c:a8:2a:ba:12:6f
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8107e-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 ioport:4000(size=256) memory:c6004000-c6004fff memory:c6000000-c6003fff
  *-network
       description: Ethernet interface
       physical id: 3
       logical name: enp0s20u2
       serial: ea:f8:17:e8:82:30
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.6 link=yes multicast=yes

Can anyone suggest what to do now?

  • @NikhilWagh Recent kernels starting with v4.15.0-33 have a bug. See these: askubuntu.com/questions/1069153/… and askubuntu.com/questions/1068826/… – pomsky Oct 19 '18 at 11:52
  • Most imported case. You must install linux-headers-generic before install rtlwifi_new driver. This case writen at the repository readme file – Ahmet Erkan ÇELİK Dec 24 '18 at 10:15
  • @Ahmet I had it was still not working. According to chili555's answer, I installed Ubuntu 18.10 and the wifi is working fine. – Nikhil Wagh Dec 25 '18 at 5:57
  • My ubuntu 18.10 bluetooth has been signal weak after kernel upgrade. I've tried every solution but not working. I'm working network cable, but wifi devices listed on wifi device list. One day I've connected to a wifi device. Bingo! bluetooth headphone weak signal fixed accidentally. I don't understand this reason but maybe someone's problem solves. – Ahmet Erkan ÇELİK Jan 10 at 11:28
5

Please refer to the bug report I linked above at posts #25 and following:

I've tested with the kernel as recommended and suggest in #25. Wifi with rtl8723b3 works again (like a charm). However, ant_sel must be set to 1 (ant_sel=1) as opposed to kernel 4.15.0-32, which required ant_sel to be set to 2 (ant_sel=2). (e.g sudo modprobe rtl8723be ant_sel=1 vs. sudo modprobe rtl8723be ant_sel=2).

At post #32, we see that kernel version 4.17-rc4 works well.

Therefore, I suggest that, if and only if the ant_sel steps don't work, then install the kernel and associated packages. The links are all the usual 64-bit packages. Be certain that yours is a 64-bit install with the terminal command:

arch

If it returns x86_64, then please proceed.

Download these packages:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17-rc4/linux-headers-4.17.0-041700rc4_4.17.0-041700rc4.201806041713_all.deb

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17-rc4/linux-headers-4.17.0-041700rc4-generic_4.17.0-041700rc4.201806041713_amd64.deb

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17-rc4/linux-image-unsigned-4.17.0-041700rc4-generic_4.17.0-041700rc4.201806041713_amd64.deb

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17-rc4/linux-modules-4.17.0-041700rc4-generic_4.17.0-041700rc4.201806041713_amd64.deb

By default, downloads go to the folder Downloads. Open a terminal and do:

cd ~/Downloads
sudo dpkg -i linux*.deb

Reboot.

EDIT: Ubuntu 18.10 that was recently released uses kernel version 4.18.0-xx. I assume that rtl8723be will work as expected. You can verify this by running a live session of 18.10. If everything works as expected, I suggest that you install it.

  • You're a life saver man. I installed Ubuntu 18.10 and wifi is working superb. Thanks a lot. – Nikhil Wagh Oct 20 '18 at 10:57
  • For all those having the same problem, install Ubuntu 18.10 and tick on the install proprietary softwares. If the problem still persist then try changing your ant_sel. – Nikhil Wagh Oct 20 '18 at 11:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.