7

I am using the default Ubuntu dock with bottom placement and org.gnome.shell.extensions.dash-to-dock extend-height set to false. With Ubuntu 18.10 this produces a noticeable visual glitch, note the black empty spaces at the edges of the dock:

click to open a screenshot

I am getting this both on an upgraded system and on a clean install inside a VM. This was working fine in Ubuntu 18.04. Also happens if the theme is set to something else than Yaru (the default theme in Ubuntu 18.10). Reboot does not help. Dock looks OK if extend-height is enabled.

Any ideas on how to fix this?

9

It looks like a bug related to adaptive/dynamic opacity: https://github.com/micheleg/dash-to-dock/issues/814

To work around this temporarily, you can set the opacity to fixed:

  1. Open Terminal and run

    gsettings set org.gnome.shell.extensions.dash-to-dock transparency-mode 'FIXED'
    
  2. Reboot or re-login.
| improve this answer | |
3

Incase if you dont want to Use "built-in theme" option from Dash-to-Dock Settings and want to get rid of the additional length colour on both sides of dock..

enter image description here

take the backup of the file

~/.local/share/gnome-shell/extensions/dash-to-dock@micxgx.gmail.com/stylesheet.css

and edit the file

~/.local/share/gnome-shell/extensions/dash-to-dock@micxgx.gmail.com/stylesheet.css

like below at line number 118

#dashtodockContainer.opaque { background-color: transparent;
}

#dashtodockContainer.transparent { background-color: transparent;
}

to show the difference I have used cyan and blue colors in above content.

enter image description here

| improve this answer | |
1

All is fixed when i switch "Default" in "Customize opacity" in Appearance tab

screenshot

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.