I have an issue with VirtualBox on Ubuntu 18.04 . It won't boot my windows VM.

When I try to boot the VM, this shows up:

The virtual machine 'Windows 10' has terminated unexpectedly during startup with exit code 1 (0x1).

NS_ERROR_FAILURE (0x80004005)
IMachine {85cd948e-a71f-4289-281e-0ca7ad48cd89}

and in another window:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall virtualbox-dkms package and load the kernel module by executing

'modprobe vboxdrv'

as root.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT. 

After the installation, I noticed this:

● virtualbox.service - LSB: VirtualBox Linux kernel module
   Loaded: loaded (/etc/init.d/virtualbox; generated)
   Active: failed (Result: exit-code) since Thu 2018-10-18 18:09:31 CEST; 4ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 9827 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)

Okt 18 18:09:31 ubuntu systemd[1]: Starting LSB: VirtualBox Linux kernel module...
Okt 18 18:09:31 ubuntu virtualbox[9827]:  * Loading VirtualBox kernel modules...
Okt 18 18:09:31 ubuntu virtualbox[9827]:  * No suitable module for running kernel found
Okt 18 18:09:31 ubuntu virtualbox[9827]:    ...fail!
Okt 18 18:09:31 ubuntu systemd[1]: virtualbox.service: Control process exited, code=exited status=1
Okt 18 18:09:31 ubuntu systemd[1]: virtualbox.service: Failed with result 'exit-code'.
Okt 18 18:09:31 ubuntu systemd[1]: Failed to start LSB: VirtualBox Linux kernel module.

I've already tried reinstalling everything, and almost everything I found on the internet, but nothing is working.

I would really appreciate if somebody can help me. :)

  • Try disabling Secure Boot in UEFI. That's probably what's preventing the VB drivers to load.
    – user880592
    Oct 18, 2018 at 16:25
  • How did you install virtualbox? Please run lsmod | grep vbox and post it! Oct 18, 2018 at 16:33
  • 2
    Possible duplicate of Virtualbox Kernel driver not installed
    – N0rbert
    Oct 18, 2018 at 16:52
  • Did you install virtual-box from the Ubuntu Software Center or from the terminal?
    – Zangar
    Oct 18, 2018 at 17:10
  • @GeorgeUdosen "apt install ..."
    – Lukas Eder
    Oct 23, 2018 at 12:52

4 Answers 4


I had this problem after updating Ubuntu:

Please, try reinstalling virtualbox-dkms: sudo apt-get install --reinstall virtualbox-dkms

I found this suggestion here: https://ubuntuforums.org/showthread.php?t=2320523.


On ubuntu 18.04 I did

sudo apt-get remove virtualbox

after that i downloaded the latest .deb file from https://www.virtualbox.org/wiki/Linux_Downloads

and installed it using gdebi

It worked and none of my vms were lost.


For me, it worked this way

I uninstalled it using

sudo apt-get purge virtualbox

And then I downloaded latest version of virtual box from https://www.virtualbox.org/wiki/Linux_Downloads and installed it.

None of my vm's were lost.


Did you install vboxdrv kernel module?

When you install virtualbox throught APT, vboxdrv already exists.

Follow the instructions in the log:


modprobe vboxdrv

You have to install the kernel module as root.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .