3

I tried installing gcc 4.4.7 with no success, using: sudo apt-get install gcc 4.4.7

I tried to run it via the source code and install a fresh one... Nothing seems to work.

I keep getting this error:

Version 4.4.7 for 'gcc' was not found

or:

Couldn't find any package by glob gcc-4.4.7....

Does anyone have any idea how I can install gcc? I'm new to Linux and have just installed it.

2 Answers 2

4

Here is how to install GCC 4.4.7 on Ubuntu 18.04:

sudo add-apt-repository 'deb http://archive.ubuntu.com/ubuntu/ trusty main'
sudo add-apt-repository 'deb http://archive.ubuntu.com/ubuntu/ trusty universe'
sudo apt update
sudo apt install gcc-4.4
1
  • Depends: libmpfr4 (>= 3.1.2) but it is not installable Commented Feb 7 at 14:18
2

The closest you can get to gcc 4.4.7 in Ubuntu 18.04 is to install gcc-4.8 from the default Ubuntu repositories. To install it open the terminal and type:

sudo apt install gcc-4.8   

The gcc package in 18.04 provides gcc 7. The latest gcc package in 18.04 is gcc-8.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .