0

I tried to use the command

make

or

make -j `getconf _NPROCESSORS_ONLN` deb-pkg LOCALVERSION=-rtai

I got the following error -

CHK     include/config/kernel.release
CHK     include/generated/uapi/linux/version.h
CHK     include/generated/utsrelease.h
CC      kernel/bounds.s
cc1: error: code model kernel does not support PIC mode
Kbuild:35: recipe for target 'kernel/bounds.s' failed
make[1]: *** [kernel/bounds.s] Error 1
Makefile:980: recipe for target 'prepare0' failed
make: *** [prepare0] Error 2

Any ideas? I have tried this: link

  • 1
    What do you mean by kernel 3.18.20? Ubuntu 18.04 does not use this kernel. This is a very old kernel. – user68186 Oct 18 '18 at 14:06
  • I know it uses 4.15. The kernel 3.18.20 is for installing rtai 5.0. – S_whynot Oct 18 '18 at 14:24
  • 2
    Possible duplicate of Kernel doesn't support PIC mode for compiling? – muru Oct 23 '18 at 3:43
  • I have tried that but it still did not work. – S_whynot Oct 23 '18 at 9:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.