1

I just created a virtual machine using ubuntu 18.04 on a kubuntu host machine. I tried to use the bidirectional shared clipboard option after installing guest additions on the guest machine. On the host machine I can't use sudo commands, which is the actual reason for me to use a virtual machine.

I already tried the solutions suggested in the first 3 answers of this post VirtualBox 4.12 Shared clipboard not working in Ubuntu14.04 except that i changed the commands in the third answer for the commands suggested in the comments, because someone said that the commands in the answer killed his ubuntu installation. None of the solutions worked.

Does anyone have any other solution?

The output of vboxmanage list extpacks on host:

Extension Packs: 1
Pack no. 0:
VNC Version: 5.1.38
Revision: 122592
Edition:
Description: VNC plugin module
VRDE Module: VBoxVNC
Usable: true
Why unusable:

Output of VBoxClient -V on guest machine:

5.1.38r122592

9
  • What is your guest system? And what is VirtualBox version on host? – N0rbert Oct 19 '18 at 10:02
  • @N0rbert Ubuntu 18.04 – Max Oct 19 '18 at 10:03
  • @N0rbert the VirtualBox Version is 5.1.38_Ubuntu r122592 – Max Oct 19 '18 at 10:12
  • I have exactly the same VirtualBox version. On host I also have installed VirtualBox extension pack (see this answer for details). What is the output of the vboxmanage list extpacks on host? Do you have any output of VBoxClient -V on the guest? – N0rbert Oct 19 '18 at 10:25
  • @N0rbert See my edited question – Max Oct 19 '18 at 10:44
1

I have just got the same problem with Ubuntu MATE 18.10 guest.

The solution is to install two packages linux-headers and build tools:

sudo apt-get install linux-headers-generic build-essential

then reinstall VirtualBox Guest Additions from ISO and then reboot. The clipboard works after reboot.

The complete list of VirtualBox services will look like below:

$ ps ax | grep VBox
  514 ?        I<     0:00 [iprt-VBoxWQueue]
  803 ?        Sl     0:00 /usr/sbin/VBoxService --pidfile /var/run/vboxadd-service.sh
 1320 ?        S      0:00 /usr/bin/VBoxClient --clipboard
 1321 ?        Sl     0:00 /usr/bin/VBoxClient --clipboard
 1330 ?        S      0:00 /usr/bin/VBoxClient --display
 1331 ?        S      0:00 /usr/bin/VBoxClient --display
 1340 ?        S      0:00 /usr/bin/VBoxClient --seamless
 1341 ?        Sl     0:00 /usr/bin/VBoxClient --seamless
 1349 ?        S      0:00 /usr/bin/VBoxClient --draganddrop
 1350 ?        Sl     0:00 /usr/bin/VBoxClient --draganddrop
 1938 pts/0    S+     0:00 grep --color=auto VBox
2
  • It's so strange. I installed those headers and for both of them I got the output that they had already been on the newest version. Then I thought "ok it wasn't that, but let's try it anyway". And now after reinstalling and rebooting: everything works fine. Thanks a lot, you are my hero of the week! :) Just for me to become a little more indepent in linux/virtualbox troubleshooting: How did you find that out now? PS: Now my sharefolder is also automatically created and mounted ;) – Max Oct 19 '18 at 13:04
  • I remembered this from previous experience. VirtualBox has kernel- and user-space parts. The guest additions will fully work if both parts are OK. Great it works :) – N0rbert Oct 19 '18 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.