I tried installing Ubuntu on HP Pavilion Power 15 laptop. I had Windows previously installed on the SSD, the installation freezes either at language selection or the screen after. I can't seem to solve the problem with other solutions on the forum. The laptop also has the following specifications:

  • 128 Gb SSD
  • 1TB HDD
  • Nvidia GTX1050 graphics card.

I'd like to install Ubuntu on the SSD drive.

  • 2
    Usually a frozen installer means you either have a corrupted ISO, a mis-made installer media, or you need to try nomodeset. Then the installer works properly on the vast majority of hardware. Since you claim to have tried non-specific "other solutions" without success, please edit your question to clearly explain in detail exactly what you tried, and exactly what led you to believe about each attempt that it did not work. – user535733 Oct 18 at 12:28
  • You need to assure the following conditions: (1) Booting in UEFI mode (disable CSM in UEFI settings) preferably with Secure Boot disabled to avoid complications with the installation of Nvidia drivers. (2) Use nomodeset as mentioned above by editing the "try Ubuntu" option of the first menu and typing it in the same line where "quiet splash" is. – GabrielaGarcia Oct 18 at 12:31
  • After installing Ubuntu you may need nomodesetas well until you install the Nvidia graphics drivers. – GabrielaGarcia Oct 18 at 12:32

I have the same issue and use the same machine.

Finally, I managed to install ubuntu-16.04-desktop-amd64. using these steps:

  1. Create a live USB boot using Rufus:

    • Partition scheme: MBR
    • Target system: BIOS or UEFI
  2. Install Ubuntu with installation type Something Else

If you cannot install on the first attempt, try again.

Currently, I'm trying to update from 16.01 to Ubuntu 18.04.

An alternative suggestion can be found in this article How to install Ubuntu on HP Pavilion Power 15.

  • i also had to install ubuntu 16, then update to ubuntu 18.04 LTS – Kyamasam Oct 21 at 11:11
up vote 0 down vote accepted

I was able to do this by setting nomodeset I followed the following steps as described here

  1. disable secure boot in bios
  2. boot ubuntu installation image from USB stick
  3. on bootmanager press e and then add "nomodeset" in front of "quiet splash", then CTRL+X
  4. Install Ubuntu

  5. After installation remove USB stick and change boot order ubuntu first in BIOS once again: in bootmanager press e and then add "nomodeset" in front of "quiet splash", then CTRL+X

  6. When in desktop, enter terminal with CTRL+ALT+T, and edit GRUB to prevent it from always starting with nomodeset:

    sudo nano /etc/default/grub
    

add nomodeset: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset", CTRL+X

sudo update-grub

reboot After that you should be able to running ubuntu.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.