6

I am trying to configure bumblebee to switch my nvidia discrete card. As well bumblebee crashes when tries to modprobe nvidia. When i try to do it manually, i face the same error:

$ modprobe nvidia

modprobe: ERROR: ../libkmod/libkmod-module.c:832 kmod_module_insert_module() could not find module by name='off'
modprobe: ERROR: could not insert 'off': Unknown symbol in module, or unknown parameter (see dmesg)

Nvidia driver version is 410, when using 390 i face the same error.

4
  • Shouldn't you be using nvidia-prime? And then switch cards using the Nvidia X Server Settings? Bumblebee is outdated, I think.
    – user880592
    Oct 18, 2018 at 15:20
  • @GabrielaGarcia I would use it, but it doesn't turn my discrete card off. Earlier I used bumblebee to shut down discrete card, and had success, but I've tried to update my nvidia drivers which broke everyhting. So my only choice is to use bumblebee. Oct 19, 2018 at 17:11
  • You're supposed to reboot after setting a different card. Did you? (I know, we don't have to in Windows, but I'm telling you how it is in Ubuntu/Linux)
    – user880592
    Oct 19, 2018 at 17:13
  • @GabrielaGarcia Yes, of course I did. I also had problems with that (login screen freeze), but there was a problem with ACPI tables. Now i can prime-select but my discrete card stays ON always, which doubles up my power discharge. Oct 20, 2018 at 11:23

1 Answer 1

19

So, IMHO, nvidia did some changes to their install. For everyone trying to get bumblebee work with their nvidia driver, you have to know that:

  1. Now nvidia library is located in /usr/lib/x86_64-linux-gnu

  2. blacklist-nvidia.conf file is located in /lib/modprobe.d/

The answer was in blacklist-nvidia.conf, which still had alias nvidia off uncommented.

2
  • 2
    Confirmed to work in 18.04 after upgrade to nvidia 390.77. Bumblebee works for me now.
    – nesuribe
    Oct 25, 2018 at 2:38
  • 2
    I'm not using bumblebee but my Ubuntu 18.04 laptop stopped loading the nvidia driver and sudo modprobe -v nvidia had the same error message as in this question. Commenting out the alias nvidia off in blacklist-nvidia.conf fixed it for me.
    – Epimetheus
    Mar 8, 2020 at 18:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .