0

I am unable to connect through an Ethernet cable at the moment so I tried to install the drivers for my TP-link archer T4UH V1 but it’s very confusing as I am completely new to Linux. When I follow the commands from the instruction manual it says syntax error even when directly copying the command onto the terminal.

Can anyone help me to install this driver?

0

Please download this file on some other computer and transfer it to the desktop of the subject computer: https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master.zip Right-click it and select 'Extract Here.' Now, in a terminal:

cd ~/Desktop/rtl8812AU_8821AU_linux-master
make
sudo make install
sudo modprobe rtl8812au

Now that we have the wireless working correctly, we'll refine this a bit.

sudo apt-get update
sudo apt-get install dkms
cd ~/Desktop/rtl8812AU_8821AU_linux-master
sudo cp -R . /usr/src/rtl8812AU_8821AU_linux-1.0
sudo dkms add -m rtl8812AU_8821AU_linux -v 1.0
sudo dkms build -m rtl8812AU_8821AU_linux -v 1.0
sudo dkms install -m rtl8812AU_8821AU_linux -v 1.0

Credit: How to install TP-LINK Archer T4U driver?

  • Thank you so much abdulla, you are very helpful. I encounter a problem when executing these commands. So I go to the file location on the desktop but when I type in the command “make” it says a bunch of stuff and at the end it says “Makefile:1584 recipe for target ‘modules’ failed make: *** [modules] error 2. Do you know what my problem is? – Daniel Tasker Oct 18 '18 at 8:49
  • Also I do have the tplink drivers downloaded if that helps? – Daniel Tasker Oct 18 '18 at 8:57
  • Share all error log you see on terminal – Saularis Oct 18 '18 at 8:59
  • daniel@ThugLifeSweg1 ~ $ cd ~/Desktop/rtl8812AU_8821AU_linux-master daniel@ThugLifeSweg1 ~/Desktop/rtl8812AU_8821AU_linux-master $ make make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.10.0-38-generic/build M=/home/daniel/Desktop/rtl8812AU_8821AU_linux-master modules make[1]: Entering directory '/usr/src/linux-headers-4.10.0-38-generic' Segmentation fault (core dumped) arch/x86/Makefile:140: CONFIG_X86_X32 enabled but no binutils support CC [M] /home/daniel/Desktop/rtl8812AU_8821AU_linux-master/core/rtw_cmd.o I will post many as there arent enough characters :( – Daniel Tasker Oct 18 '18 at 9:13
  • In file included from ./include/linux/cgroup-defs.h:16:0, from ./include/linux/sched.h:61, from ./include/linux/kasan.h:4, from ./include/linux/slab.h:118, from /home/daniel/Desktop/rtl8812AU_8821AU_linux-master/include/osdep_service_linux.h:29, from /home/daniel/Desktop/rtl8812AU_8821AU_linux-master/include/osdep_service.h:41, from /home/daniel/Desktop/rtl8812AU_8821AU_linux-master/include/drv_types.h:32, from /home/daniel/Desktop/rtl8812AU_8821AU_linux-master/core/rtw_cmd.c:22: – Daniel Tasker Oct 18 '18 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.