1

I am trying to install pandoc 2.3.1 in my Ubuntu 18.04.1 LTS.

First, I remove any old pandoc version (in my case is pandoc 1.19.2.1)

manolo@manolo:~$ sudo apt-get remove  pandoc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'pandoc' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 39 not upgraded.

manolo@manolo:~$ sudo apt-get remove --auto-remove pandoc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'pandoc' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 39 not upgraded.

manolo@manolo:~$ sudo apt-get purge pandoc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'pandoc' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 39 not upgraded.

Then, I run the following command to check the pandoc version that should have given me a blank result because pandoc is not installed. Although, I get the following result:

manolo@manolo:~$ pandoc -v
pandoc 1.19.2.1
Compiled with pandoc-types 1.17.0.4, texmath 0.9, skylighting 0.1.1.4
Default user data directory: /home/atai/.pandoc
Copyright (C) 2006-2016 John MacFarlane
Web:  http://pandoc.org
This is free software; see the source for copying conditions.
There is no warranty, not even for merchantability or fitness
for a particular purpose.

Then, I try installing the new latest version of pandoc:

manolo@manolo:~$ sudo dpkg -i /home/atai/Desktop/pandoc-2.3.1-1-amd64.deb
Selecting previously unselected package pandoc.
(Reading database ... 263668 files and directories currently installed.)
Preparing to unpack .../pandoc-2.3.1-1-amd64.deb ...
Unpacking pandoc (2.3.1-1) ...
Setting up pandoc (2.3.1-1) ...
Processing triggers for man-db (2.8.3-2) ...

Although, when I check the pandoc version I still have the 1.19.2.1 installed:

manolo@manolo:~$ pandoc -v
pandoc 1.19.2.1
Compiled with pandoc-types 1.17.0.4, texmath 0.9, skylighting 0.1.1.4
Default user data directory: /home/atai/.pandoc
Copyright (C) 2006-2016 John MacFarlane
Web:  http://pandoc.org
This is free software; see the source for copying conditions.
There is no warranty, not even for merchantability or fitness
for a particular purpose.

My guess is something regarding the path where pandoc is being installed.

manolo@manolo:~$ whereis pandoc
pandoc: /usr/bin/pandoc /home/atai/anaconda3/bin/pandoc /usr/share/man/man1/pandoc.1.gz

manolo@manolo:~$ type pandoc
pandoc is hashed (/home/atai/anaconda3/bin/pandoc)
  • My guess is that sometime in the past you installed pandoc using a non-deb method. Please edit your question to include the complete output of whereis pandoc – user535733 Oct 18 '18 at 1:52
  • You are right, the previous user installed pandoc using a non-deb method. I still wonder how to fix this. – Antarqui Oct 18 '18 at 2:08
  • It seems to be a path issue: manolo@manolo:~$ which pandoc /home/atai/anaconda3/bin/pandoc – Antarqui Oct 18 '18 at 2:50
  • 2
    Since the version you wish to remove seems to be installed in the anaconda environment, it was likely installed using pip/conda tools. Look for those tools to remove it. – user535733 Oct 18 '18 at 11:18
  • Thank you @user535733 that worked perfectly. I also found this post very useful. – Antarqui Oct 18 '18 at 23:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.