I have been struggling for the last couple of days to figure out why my thunderbolt ports (on the left side of the XPS 13) stopped working on Ubuntu 18.04. The right side USB port works well and charging works on all the ports. Also, because I have a dual boot with Windows 10, I checked if I had the same issues and, indeed, the USB ports don't work on Windows. By USB ports not working I mean that neither ethernet, HDMI, external memory nor USB hub are recognized.

I don't know if it is a coincidence but it happened after I tried to find a way to transfer file to my android device. Following this post (Trying to install android-file-transfer Ubuntu 18.04 Bionic) I did the following

sudo add-apt-repository "deb http://ppa.launchpad.net/samoilov-lex/aftl-stable/ubuntu artful main"
sudo apt install android-file-transfer
sudo apt install libmtp-common mtp-tools libmtp-dev libmtp-runtime libmtp9

Here are the things I noticed so far

  • Windows can crash when I plugin a device on the left side (but not always) with a blue screen and a forced reboot
  • When it does not crash, Windows shows an error "device not recognized"
  • Ubuntu does absolutely nothing when I plugin a device on the left side
  • Wifi/bluetooth work fine on both Ubuntu and Windows

I've been trying to solve that non-working USB port issue for a while now and here are the steps I followed:

I run out of ideas so if anyone has a solution please feel free to reply. Thank you a lot.

I have a Dell XPS 9370 from 2018 with configuration

$ inxi -ACDF
System:    Host: XPS-13-9370 Kernel: 4.15.0-36-generic x86_64 bits: 64 Desktop: Gnome 3.28.3
           Distro: Ubuntu 18.04.1 LTS
Machine:   Device: laptop System: Dell product: XPS 13 9370 serial: N/A
           Mobo: Dell model: 0H0VG3 v: A00 serial: N/A UEFI: Dell v: 1.5.1 date: 08/09/2018
Battery    BAT0: charge: 37.0 Wh 71.1% condition: 52.0/52.0 Wh (100%)
CPU:       Quad core Intel Core i7-8550U (-MT-MCP-) cache: 8192 KB
           clock speeds: max: 4000 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz 5: 800 MHz 6: 800 MHz
           7: 800 MHz 8: 800 MHz
Graphics:  Card: Intel UHD Graphics 620
           Display Server: x11 (X.Org 1.19.6 ) driver: i915 Resolution: [email protected]
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) version: 4.5 Mesa 18.0.5
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel Sound: ALSA v: k4.15.0-36-generic
Network:   Card: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci
           IF: wlp2s0 state: up mac: 9c:b6:d0:88:8e:5b
Drives:    HDD Total Size: 256.1GB (44.3% used)
           ID-1: /dev/nvme0n1 model: KXG50ZNV256G_NVMe_TOSHIBA_256GB size: 256.1GB
Partition: ID-1: / size: 168G used: 106G (67%) fs: ext4 dev: /dev/nvme0n1p5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 53.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 342 Uptime: 25 min Memory: 2798.2/7692.8MB Client: Shell (bash) inxi: 2.3.56

List of my USB devices

$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0489:e0a2 Foxconn / Hon Hai 
Bus 001 Device 003: ID 0bda:58f4 Realtek Semiconductor Corp. 
Bus 001 Device 005: ID 27c6:5385  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Here are some kernel errors. Notably the "Cannot enable. Maybe the USB cable is bad?" that happends any time I connect a USB device on one of the left USB port.

$ dmesg
[  729.934551] usb 1-1: USB disconnect, device number 2
[  755.529789] usb usb3-port1: Cannot enable. Maybe the USB cable is bad?
[  755.529931] xhci_hcd 0000:07:00.0: Command completion event does not match command
[  755.529950] xhci_hcd 0000:07:00.0: Error while assigning device slot ID
[  755.529960] xhci_hcd 0000:07:00.0: Max number of devices this xHCI host supports is 64.
[  755.529965] usb usb3-port1: couldn't allocate usb_device

2 Answers 2


You should try to boot on a USB key with a Linux distro. The portable Linux distros come with a robust and comprehensive driver set.

If that does not work you probably got a hardware failure.

  • I tried to check the USB ports with a live USB key but the same error occurs.
    – Amzocks
    Oct 17, 2018 at 22:11
  • Amzocks, dit you find a solutions to this? I have the same issue (usb-c is giving me power from the external monitor, but the same xhci_hcd error). Tried installing ubuntu 19.04 but no luck (dmesg now gives me 'Unknown WMI event type 0x12)
    – Dante
    Jul 23, 2019 at 6:41

Finally, I had to send my computer back to the factory. They changed the whole thing and sent it back to me. Apparently it was hardware-related.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .