17

Today I have updated from my Ubuntu 18.04 to 18.10 by software upgrade app ( coudn't wait till tomorrow 😆). It took a bit of time, but at the end of it I was asked to restart my PC. Upon restarting, I get to boot runtime.

The boot log on screen passed numerous processes like gnome manager and stopped on "Started bpfilter". I waited 15 min., but nothing changed. Tried to restart the PC manually two times, but the result was still the same.

The interesting bit for me, after the message, it seems like an instance of terminal is given to me, - I can freely write letters. Though commands like cd, ls are not working.

Everything is simply echoed back

My GPU is NVidia GTX 1060, cpu intel i5-7500. I dual boot along with Windows 10.

What would be your recommendations to fix this or debug what could be wrong?

  • 1
    Hello and welcome to AU. My recommendation is to expand your question a little bit: did it happen directly after installation, update,... What did you try ? – Marc Vanhoomissen Oct 17 '18 at 14:07
  • 1
    Hello, thanks for the warm reply, I added a bit more info. If anything else is needed, please feel free to ask. 🙂 – Akimbas Oct 17 '18 at 14:37

10 Answers 10

16

Actually, scratch that. Do this: edit /etc/gdm3/custom.conf and uncomment the line:

#WaylandEnable=false

The issue also doesn't seem to appear in a fresh install of Ubuntu 18.10.

Go here and press the affects me button to raise awareness. Feel free to provide information/logs needed by the developers in the comments. Thank you.

Removing the nvidia proprietary drivers seems to fix the issue. Go into recovery mode by pressing Shift during boot and run sudo apt-get remove --purge nvidia-* Say goodbye to gaming, though. I have filled a bug in Launchpad. You might want to press the "affects me" button. Thank you.

  • 3
    Even though I had a fresh install of 18.10, after some update I started facing this issue. The fix worked for me too. Thanks. – Dhruva Sagar Dec 9 '18 at 2:14
  • I had this problem on a Hyper-V virtual machine instance of Ubuntu 8.10 and this fixed it, thanks. – nakedfanatic Jan 24 at 22:21
  • 18.04. 3,line was already uncommented but issue was present. – NelsonGon Aug 24 at 6:38
4

On Ubuntu 18.10. kernel 4.18.0-12-generic, GNOME Shell 3.30.1 - X11, since a Dec 9 update, login kept hanging on Started bpfilter -- I think a possible conflict between systemd and bpfilter (I think managed by the kernel.) The following suggested fixes had no effect on my system:

  1. Removing nVidia drivers (my laptop uses Intel graphics, no nVida drivers installed, so this recommendation didn't apply,)
  2. Reverting to previous kernel 4.18.0-11-generic,
  3. Disabling Wayland in gdm3,
  4. Switching to LightDM display manager (identical hang.) I tried SLiM because it claimed not to require systemd, and it now enables normal login for me. Debian-branded, but allows changing the login background to something generic.

My fix procedure:

In Recovery Mode, select <Enable Networking> (this allows APT to connect online while in Recovery Mode,) then select <Drop to Shell Prompt>. Run (as root -- enter whoami to verify)

apt update && apt install slim

to install SLiM. To switch the display manager to SLiM, in Recovery Mode run (as root):

dpkg-reconfigure gdm3

then select SLiM, then 'restart now'.


SLiM will probably be a temporary recourse; with Ubuntu's continuing development I think systemd will be integral, so I've kept GDM3 and LightDM installed, in case a future kernel or systemd update fixes this issue.

This boot hang seems to be an upstream issue reported by users on other distros besides Ubuntu as well, Arch Linux especially.

2

I just had the same set of symptoms with the best results from the previous post:

  1. Recovery Mode
  2. apt-get install slim
  3. dpkg-reconfigure gdm3
  4. reboot
  • 3
    This seems like a re-hash of the upvoted answer. – Charles Green Feb 8 at 17:08
2

Ok, I might get downvoted to oblivion and get my answer privilege taken away because this is only an improvement (Or I would like to think so) but I have to answer this.

Note: this is an improvement over @zanna 's answer in this same thread, but I don't have comment privilege yet so I'm posting this as a separate answer.

If you have followed @zanna 's answer in this thread and you are using SLiM display manager, and you have decided you don't like this very much/would like to go back to gdm3 (No Unity dock and takes away most of the useful functionalities in Ubuntu, you cannot even tap-to-click without a lot of tinkering around) maybe this will help you get back to gdm3.

The 'Started BPFilter' bug happens mostly in Ubuntu 18.04 (and I've also seen a few cases in 18.10). Go on, Install SLiM as @zanna has suggested and check if that works.

Note 2: there are a couple of answers in other thread suggesting you use LightDM. It has not worked for me. I reached the login screen and I was forever re-directed to the same screen even if I input the right credentials. You are free to go play around using the command line from there (Ctrl + Alt + Del or something) but here is a thread on why that wouldn't probably work.

Thread (Even LightDM doesn't work for me, Is there no respite!): [https://www.reddit.com/r/Ubuntu/comments/9hagsd/ubuntu_1804_just_keeps_returning_to_login_screen/]

Note 3: (If you have come this far, I take it you have also gotten rid of your Nvidia Drivers, which for most of you did not exist to begin with! [Yeah, I did the purge too only to find they don't exist]).

Solution: (Not really, since you need to move away from 18.04).

  1. As the top answer has suggested, in /etc/gdm3/custom.conf uncomment the line that says

    #WaylandEnable=false

    Once you do it

  2. Do

    sudo do-release-upgrade

    This should get you the next immediate Ubuntu version. However, this is not the Development version (which actually works with gdm3 for me). So next, do:

    sudo do-release-upgrade -d (-d flag for development branch).

This will ask you to edit a text file and change the version from LTS to normal (Follow the error message!).

Once this is done, go into recovery, and do:

dpkg-reconfigure gdm3 and choose gdm3 this time (Don't choose SLiM/ LightDM).

That is it! Tada! Everything works now!

1

My Ubuntu is 18.04.2 LTS, and I got the exactly the same problem. I tried many ways searched from google but failed.

The final solution for me is (which I don't know why it works):

  1. First you need to login after "Started bpfilter". Type: your_username→enter→password, Then you will get a terminal which is the same as the one you open in GUI when it works. Actually now you can control you computer with it.

  2. sudo apt-get install lightdm, Enter to confirm installation.

  3. In my case, after the installation of "lightdm", there will be a popup GUI which asks you for confirming something as default setting with two choice, "gdm" and "lightdm". While, I still choose the "gdm" here(don't ask me why, I am also confused).

  4. Restart. My GUI come back! and I tried restart again which proved the problem is solved. (Even I am still googleing "what is gdm and lightdm?").

  5. Open terminal and type sudo apt-get remove lightdm to remove the lightdm (I am sorry~)

1

Well, for me (ubuntu 18.04), it turns out to be the opposite of others. I had to set the WaylandEnable value to true to be able to boot the system.

1

I had the same problem and found out that I caused it by editing the banner section in the file

/etc/gdm3/greeter.dconf-defaults.

I had to make the lines for banner, message and comment again and it did not hang anymore.

0

If you are using ubuntu 18.10 on VirtualBox and have been playing with settings of the virtual machine, it might help to set Settings->Display->Enable 3d acceleration back on.

0

I had the same issue on Zorin 15 - which is based on Ubuntu 18. Fortunately, I can still SSH to the box.

I simply did sudo apt-get remove gnome-shell and then sudo apt-get install gnome-shell

0

Installing LightDM worked for me. I'm on an iMac late 2013 with Ubuntu 19.04 and kernel 5.0.0-23-generic. I installed SLiM first, but since I run a two-monitor setup, the login screen was just messed up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.