I need to install those package from ubuntu packages: https://packages.ubuntu.com/bionic/libssl1.1

I'm using ubuntu 18.04 with aptitude.

When I'm searching for that in aptitude gui, there is only "lib1.0.0-dbg" package found.

How to install libssl1.1 directly from package URL?

  • Please edit your question and post of the results of a simulated libssl1.1 installation using the command sudo apt-get install -s libssl1.1 To install libssl1.1 for real, run the same command without the -s option. – karel Oct 17 at 8:57
  • your command also worked after adding repository to sources list – KrystianK Oct 17 at 9:30

You should add repository to your sources list: sudo echo 'deb http://security.ubuntu.com/ubuntu bionic-security main' >> /etc/apt/sources.list && sudo aptitude update

  • 1
    The sudo only has effect on the echo command, not the redirection of the output. Try echo 'deb http://security.ubuntu.com/ubuntu bionic-security main' | sudo tee -a /etc/apt/sources.list instead. – Stefan Hamcke Oct 17 at 9:03
  • ok thanks, now it shows – KrystianK Oct 17 at 9:29

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.