5

Hello Guys I am facing an odd issue, I am trying to enable the auto-save-session on Ubuntu 18.04.1 LTS, I try to follow some answers already here, but I wasn't able to restore my gnome session.

I use this link to configure my Ubuntu: https://medium.com/@pwaterz/how-to-dual-boot-windows-10-and-ubuntu-18-04-on-the-15-inch-dell-xps-9570-with-nvidia-1050ti-gpu-4b9a2901493d

My kernel version is 4.18.14-041814-lowlatency, and gnome:3.28 before post this question here I had been tried to do the following:

https://www.howtogeek.com/203952/how-to-automatically-remember-running-applications-from-your-last-session-in-ubuntu-14.04/

Review / edit startup programs rembered by "Remember Currently Running Applications"

I am not sure about what I am doing wrong but, if you can give me some help I would appreciate that.

5

Ubuntu dropped session saving long ago because it never worked well. Gnome Shell, the desktop environment that Ubuntu 18.04 uses, apparently does not support it as such.

  • Sleep (computer stays on in very low power use mode) and hibernate (computer fully shuts down after saving memory to the hard disk, and reloads the memory content on the next startup) to turn off your computer functionally allow the same, i.e. continue later where you left off. Unfortunately, sleep and hibernate may not work well on your hardware. Sleep works in many cases, but hibernate represents issues on many hardware, to the extent that on Ubuntu, the possibility to hibernate is not enabled by default.
  • Alternatively, you may try the well maintained Gnome Shell extension Window Session Manager.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.