0

Is it possible to install GnuPG 2.2 in Ubuntu 16.04?

According to https://lists.gnupg.org/pipermail/gnupg-announce/2018q3/000428.html there is a maintenance version 2.2.10. This link also tells how to install it but it looks to me that one has to compile all the stuff, i.e. there is no package to be installed by sudo apt-get ... or the like. Is that right?

  • I am using Thunderbird 60.2.1 (64 Bit) in connection with
  • Enigmail v. 2.0.8.
  • Gpg is currently still on version 1.4.20, which looks like far outdated.

What are the right stable versions which work together well and which are maintenanced such that I stay with a stable combination of the set T hunderbird+Enigmail+gpg?

Which set would be "natural" in ubuntu 16.10?

  • My Lubuntu 18.04 LTS, installed and up to date has gpg (GnuPG) 2.2.4. – sudodus Oct 16 '18 at 18:54
1

GnuPG is one base package for security and have deep dependencies, that's the reason it's not possible to build and install it following the debian packaging model.

    ├─ gnupg2
    │    ├─ dpkg (>= 1.15.4)
    │    ├─ gnupg-agent (= 2.1.11-6ubuntu2)
    │    ├─ install-info
    │    ├─ libassuan0 (>= 2.0.1)
    │    ├─ libbz2-1.0
    │    ├─ libc6 (>= 2.15)
    │    ├─ libgcrypt20 (>= 1.6.1)
    │    ├─ libgpg-error0 (>= 1.14)
    │    ├─ libksba8 (>= 1.2.0)
    │    ├─ libreadline6 (>= 6.0)
    │    ├─ libsqlite3-0 (>= 3.7.15)
    │    └─ zlib1g (>= 1:1.1.4)
    ├─ dpkg
    │    ├─ libbz2-1.0
    │    ├─ libc6 (>= 2.14)
    │    ├─ liblzma5 (>= 5.1.1alpha+20120614)
    │    ├─ libselinux1 (>= 2.3)
    │    ├─ tar (>= 1.23)
    │    └─ zlib1g (>= 1:1.1.4)
    ├─ libbz2-1.0
    │    └─ libc6 (>= 2.4)
    ├─ libc6
    │    └─ libgcc1
    ├─ libgcc1
    │    ├─ gcc-6-base (= 6.0.1-0ubuntu1)
    │    └─ libc6 (>= 2.14)
    ├─ gcc-6-base
    ├─ liblzma5
    │    ├─ libc6 (>= 2.14)
    │    └─ multiarch-support
    ├─ multiarch-support
    │    └─ libc6 (>= 2.3.6-2)
    ├─ libselinux1
    │    ├─ libc6 (>= 2.14)
    │    └─ libpcre3
    ├─ libpcre3
    │    ├─ libc6 (>= 2.14)
    │    └─ multiarch-support
    ├─ tar
    │    ├─ libacl1 (>= 2.2.51-8)
    │    ├─ libc6 (>= 2.17)
    │    └─ libselinux1 (>= 1.32)
    ├─ libacl1
    │    ├─ libattr1 (>= 1:2.4.46-8)
    │    └─ libc6 (>= 2.14)
    ├─ libattr1
    │    ├─ libc6 (>= 2.4)
    │    └─ multiarch-support
    ├─ zlib1g
    │    └─ libc6 (>= 2.14)
    ├─ gnupg-agent
    │    ├─ libassuan0 (>= 2.3.0)
    │    ├─ libc6 (>= 2.15)
    │    ├─ libgcrypt20 (>= 1.6.1)
    │    ├─ libgpg-error0 (>= 1.14)
    │    ├─ libnpth0 (>= 0.90)
    │    ├─ libreadline6 (>= 6.0)
    │    ├─ pinentry
    │    └─ pinentry-curses
    ├─ libassuan0
    │    ├─ libc6 (>= 2.14)
    │    └─ libgpg-error0 (>= 1.14)
    ├─ libgpg-error0
    │    └─ libc6 (>= 2.15)
    ├─ libgcrypt20
    │    ├─ libc6 (>= 2.15)
    │    └─ libgpg-error0 (>= 1.14)
    ├─ libnpth0
    │    └─ libc6 (>= 2.17)
    ├─ libreadline6
    │    ├─ libc6 (>= 2.15)
    │    ├─ libtinfo5 (>= 6)
    │    └─ readline-common
    ├─ libtinfo5
    │    └─ libc6 (>= 2.16)
    ├─ readline-common
    │    ├─ dpkg (>= 1.15.4)
    │    └─ install-info
    ├─ install-info
    │    ├─ libc6 (>= 2.14)
    │    └─ dpkg (>= 1.16.1)
    ├─ pinentry
    ├─ pinentry-curses
    │    ├─ libassuan0 (>= 2.0.1)
    │    ├─ libc6 (>= 2.14)
    │    ├─ libgpg-error0 (>= 1.14)
    │    ├─ libncursesw5 (>= 6)
    │    └─ libtinfo5 (>= 6)
    ├─ libncursesw5
    │    ├─ libc6 (>= 2.14)
    │    └─ libtinfo5 (= 6.0+20160213-1ubuntu1)
    ├─ libksba8
    │    ├─ libc6 (>= 2.14)
    │    ├─ libgpg-error0 (>= 1.14)
    │    └─ multiarch-support
    └─ libsqlite3-0
         └─ libc6 (>= 2.14)

It's better to upgrade to a newer release, since the packages on each release are frozen to meet stability and compatibility among them.

In case you still need to install newer packages and want to get your hands dirty try,

https://gist.github.com/vt0r/a2f8c0bcb1400131ff51

Cheers!

  • I am just upgrading to Xubuntu 18.04. Which Version of GnuPG is married with that version? – Adalbert Hanßen Feb 14 at 16:46
  • Bionic (18.04) comes with GnuPG 2.2.4, Disco (19.04) will ship 2.2.12 – Ark74 Apr 10 at 1:02
0

See this gist for compile and install GnuPG 2.2.x on Ubuntu :

https://gist.github.com/romen/b7bac24d679d91acabb27bfcdabbee01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.