3

Recently I have installed Ubuntu 18.04.1 on my laptop (Dell Precision M4700, 16GB RAM), it's quite pure at the moment. The problem is that Evince 3.30.0 produces segmentation fault (core dumped) on launch. It is happening since the system was installed and purging and reinstalling (through Synaptic as well) did not help. Any ideas how to make it work?

I entered

~/.local/share/gnome-shell 

to check what is in the extensions folder - it happens, there is no such folder (no folders at all), 'ls' in /gnome-shell produces:

application_state

Swapping to another (freshly made) user and running Evince there produces the same result.

Running sudo debsums -s provided output:

debsums: changed file /usr/share/X11/xkb/symbols/pl (from xkb-data package)

which is a file I have edited manually. Having it replaced by the original file (and deleting that new user I made) I got some more output from running evince in terminal:

Attempting to read the recently used resources file at 
'/home/january/.local/share/recently-used.xbel', but the parser failed:
Failed to open file “/home/january/.local/share/recently-used.xbel”: 
Permission denied.
Segmentation fault (core dumped)

This file had permission to read and write for my user, but had no permissions for my group. I edited these permission to provide my group with read an write and now it's just Segmentation fault like before when I run Evince.

I purged Evince again also with Synaptic to install version 3.28.2-1 (through Synaptic). First of all I encountered an error when I used GUI Apply button when trying to install Evince again:

E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
E: Unable to lock the download directory.

The error did not appear though when I selected Edit->Apply Marked Changes. Reinstallation still produces Seg.fault when running Evince.

Running sudo evince I get:

No protocol specified
Unable to init server: Could not connect: Connection refused
Cannot parse arguments: Cannot open display: 

As things happen out of random sometimes I managed to get an error from evince in GUI (splash would you call it?), sorry for it being quite big I wanted to include all possible data.

https://i.imgur.com/Q8zHcV0.jpg

Running fsck in recovery root command line yielded no errors.

I did memtest a couple of days ago and then I did one after doing the fsck, receiving this result:

Older: https://i.imgur.com/ri3oAmP.jpg

Newer: https://i.imgur.com/tsQ3dSY.jpg

  • Welcome! It would be very difficult to diagnose without some additional details, such as: the Ubuntu version, evince package version, the complete output prior to the crash, and any other possibly useful details. – valiano Oct 16 '18 at 18:21
  • Sadly, the only output I get is just the "Segmentation fault (core dumped)" no other information is provided. I'm using Ubuntu 18.04.1 LTS, evince package is the one got from the Software Center (I believe the one I am getting also through apt-get is the same) - version 3.30.0. Can't really give any more details just as they are not present. – Smoksul Oct 16 '18 at 18:34
  • Evince 3.30.0 doesn't appear to be the default version used in 18.04.1... oh, it's a snap package. Have you installed any fonts? Themes? In terminal, type evince and edit your question to include the error messages. – heynnema Oct 16 '18 at 19:24
  • As I said, the only error message (through terminal, running evince in GUI produces nothing at all) is the Segmentation Fault. Regarding the fonts I doubt I have installed some of them manually. I installed TeXMaker as well as MikTex, these could bring in some more fonts; also I have edited a certain xkb file to change the layout of my keyboard slightly. – Smoksul Oct 16 '18 at 19:32
  • Older laptop? How much RAM? Where/how did you install the extra fonts? Have you tried removing them to see if it impacts Evince? Have you installed any GNOME extensions? Report back to @heynnema – heynnema Oct 16 '18 at 19:34
0

From the comments...

We've got a malloc error with Evince.

Step #1:

To check the file system on your Ubuntu partition for errors...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /
  • repeat the fsck command if there were errors
  • type reboot

If for some reason you can't do the above...

  • boot to a Ubuntu Live DVD/USB
  • start gparted and determine which /dev/sdaX is your Ubuntu EXT4 partition
  • quit gparted
  • open a terminal window
  • type sudo fsck -f /dev/sdaX # replacing X with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot

Step #2:

Boot to the Ubuntu Live DVD/USB and run memtest for one complete pass.

Update #1:

Memtest showed a memory failure, as I suspected. Remove or replace some RAM sticks.

  • Sorry for replying so late, I was very busy last days, the post got updated accordingly to your suggestions – Smoksul Oct 20 '18 at 7:09
  • @Smoksul as I had suspected, bad RAM. Remove or replace a RAM stick. – heynnema Oct 20 '18 at 13:19
  • 1
    that's quite surprising. I am running all kind of software without any issues on Windows, on Fedora, never had a bluescreen nor anything of that sort. I will try to maybe remove some of the RAM sticks and look for the bad one (provided it's not a malfunction of them being combined) in the future. Could it lead to more damage if I did not remove/replace the RAM stick soon (if it is actually malfucntioning)? – Smoksul Oct 20 '18 at 14:11
  • If you've mixed and matched different RAM sticks, that could certainly lead to a memtest error. If you have 4 RAM sticks, you can remove 2 paired sticks, rerun memtest, and when you get a pass, retry evince. Memory normally needs to get RAM added/removed in pairs, for memory interleaving performance reasons. Hence the suggestion to remove 2 RAM sticks... but you have to look closely to make sure to remove the proper pairs. Don't wait to repair this. See sudo lshw -c memory for a clue. Report back to @heynnema – heynnema Oct 20 '18 at 14:16
1

Got the same error since yesterday on evince 3.28.4 (exactly as described), no memory faults, devs, check what were the mods since yesterday both on evince and 4.15.0-43-generic 64-bits. Checked /var/log/apt/history.log

and between the days evince was working and then not working I have: the content of this file , no reference to evince:amd64 (3.28.4-0ubuntu1) or any of the installed libraries: libevdocument3-4:amd64 (3.28.4-0ubuntu1), libgxps2:amd64 (0.3.0-2), libspectre1:amd64 (0.2.8-1), libevview3-3:amd64 (3.28.4-0ubuntu1)

No evidence of any changed dependencies as provided by the output of ldd command:

It thus seems that 3.28.4 is corrupted.

finally solved the problem with:

sudo snap install evince  # version 3.30.2

and had everything working, with some gtk warnings if I call evince from the command-line. There is a drawback, evince installed through cannot access /tmp and opening a pdf through Thunderbird or Firefox will fail. You will have to save it first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.