0

first of all thanks for your time and sorry for my english and my lack of computer skills. I have a problem with my HP Pavilion g6 Notebook. I made a Bootable USB with a Lubuntu 18.04 ISO using Rufus. However there's no way I can boot it in UEFI mode on Windows 8.1. I disabled secure boot and fast boot and I also tried to force the USB boot but an error occurred saying that "The device have failed to boot". Same thing using a DVD. Anyway when I enabled Legacy Mode everything has worked fine and I made to install the new OS. The only issue was that GRUB didn't showed up and I had to manually boot into it.

Since I've read that two different OS should be both installed in the same bios (Legacy or UEFI) can you help me to resolve the UEFI issue on my notebook?

  • You need to first enable USB booting in your UEFI bios, then trigger boot selection during booting up. Select USB from the EFI boot selection menu. – Bernard Wei Oct 16 '18 at 17:45
  • @BernardWei I have no option concerning the usb boot in the UEFI bios. The only thing I can do is change the priority order and give USB devices first priority. – anto10 Oct 16 '18 at 17:54
  • I have noticed, that some HP computers do not want to boot via grub, when there is a GUID partition table, GPT. But such computers can boot via grub, when there is an MSDOS partition table (MBR) and when there is an ISO9660 system. -- Ubuntu live drives boot via grub in UEFI mode. -- Have you tried to boot from the DVD in UEFI mode? It has an ISO9660 system (cloned from the iso file) and should boot, if grub+gpt is the problem. Otherwise we have to look for something else. – sudodus Oct 16 '18 at 19:18
  • @sudodus yes I tried to boot via DVD but it gave the same error. I really don't know what to do. I've checked all the guides and forum that talk about this but I haven't found anyone with my problem. I guess I can only give up and install Lubuntu in Legacy mode while Windows is in UEFI. I just hope that this won't cause more problems.. – anto10 Oct 16 '18 at 19:31
  • With Rufus you need to select the option GPT/UEFI before burning the ISO. If you don't it will work for BIOS/Legacy only. But now that you have Ubuntu installed you can redo the USB with MKUSB that always works properly. – GabrielaGarcia Oct 17 '18 at 5:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.