5

I have a Lenovo 330s laptop with a 4GB AMD Radeon 540 dedicated graphics. When I check the system details, It's showing only the onboard intel UHD graphics. How can I make my dedicated graphics to work. Any help would be appreciated.

enter image description here

Update #1

When I tried this code lspci -nn | grep -E 'VGA|Display'

It shows

enter image description here

Update #2

I have followed this link for installing the driver https://amdgpu-install.readthedocs.io/en/amd-18.30/. The driver got installed without an error. I restarted the laptop, checked the about page. Still It is showing UHD.

Update #3

I tried to install amdgpu-pro, now the system is stuck on the ubuntu logo.

Any help would be appreciated.

  • This question is outdated. my AMD gpu is detected in 18.10. – Ranjith Varadan Feb 6 at 10:44
1

I would recommend first of all to not install the drivers coming from outside the distribution unless you really know that you need them. Ubuntu 18.04 is pretty new and the open source drivers for AMD are in great shape.

The situation is not so great for multi-gpu configurations though. But if you just want to use the AMD graphics card instead of the Intel one, there is usually a workaround that works pretty well.

In your laptop BIOS, you usually can choose which one will be the default active graphics card. You should choose there the AMD one. That will be the main GPU from now on and it will be the used by Linux.

Since it seems that you have issues with your graphical environment, I would reinstall the distribution from scratch if you don't know how to perform a cleanup of the drivers that you installed separately.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.