I have Canon Pixma G3012 All-in-One Wireless Ink Tank Colour Printer

I am trying to scan a document from my Linux Ubuntu 18 installed PC using simple scan software.

Connected the device into PC over USB and powered on. Opened simple scan software and tried to scan the document. But got the message as "no scanner available please connect a scanner"

Already installed the driver package named scangearmp2-3.30-1-deb.tar.gz.

Used command sane-find-scanner and got below result

found USB scanner (vendor=0x04a9 [Canon], product=0x183b [G3010 series]) at libusb:001:004
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

Issued command scanimage -L and got below results.

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Referred below two links.


After that manually added below line in file named /etc/sane.d/genesys.conf

# Canon PIXMA G3012
usb 0x04a9 0x183b

Run the command scanimage -L again but still got scanner not detected message.

Any help is much appreciated.

Adding to this Printing function is working fine for this device. Tested and verified but difficulty in scanning.

Okay. There is an improvement.

I have installed the scangearmp2-3.60-1-deb.tar.gz package by removing scangearmp2-3.30-1-deb.tar.gz. After that scanning is working by initiating the command "scangearmp2". But still simple-scan doesn't detect scanner.

Found below comment from link

Canon MB2320: Scangear works, but simplescan and xsane don't find scanner

Canon does not develop SANE drivers for their scanners but they provide an own solution scangearmp for basic scan functions. This will of course not allow using SANE backends such as simplescan or xsane

For many PIXMA scanners there is a SANE implementation sane-pixma but I could not test if these work or can be made working with the Canon MAXIFY series.


Any idea how the sane-pixma can be installed in ubuntu18.04?

  • Tried below link and installed sane-pixma but no luck. Seems canon pixma G3012 is not supported yet. salsa.debian.org/debian/sane-backends
    – mth
    Oct 20, 2018 at 0:54
  • You need to update your hplip drivers and your scanner will start working again
    – Skynse
    Jul 15 at 5:04
  • @Skynse hplip is HP-specific software. Updating it will not affect the operation of a Canon device. Jul 26 at 12:50

7 Answers 7


I had a similar issue:

I have an HP All-in-One printer which includes also scanner.

The printer worked OK, but the scanners didn't. The device was pinged properly (also the HTTP interface worked OK).

So I followed the instructions in this URL: https://help.ubuntu.com/community/ScanningHowTo#LAN-based_scanners (Under title "LAN based scanners")

After performing:

sudo hp-setup -i

(while is the local IP address of the printer/HP-device.)

Then the scanner worked properly.

  • 1
    I also had to install qt5: sudo apt install python3-pyqt5 for that hp-setup to work Apr 13, 2021 at 19:15

Try this: Go to ScanGearmp2 and download or automatically install the file scangearmp2_3.50.6_amd64.deb

It works for me, Canon TS3151 printer and scanner on a clean install of Xubuntu 18.04


scangear is a frontend to sane. Xsane and simple-scan are also frontends (not backends as erroneously said earlier).

scangearmp does not provide a backend for SANE to use. Xsane and simple-scan cannot connect to something that does not exist.


I had this issue with a Brother DCP-L3550CDW. Pinging the scanner/printer with brsaneconfig4 -p worked fine, but scanimage -L and simple-scan didn't see the scanner.

The solution was to add "brother4" to /etc/sane.d/dll.conf.

I got this solution from this blog post


I had the same problem. I was able to scan through scangearmp2 but was unhappy with the result and couldn't get it to work with Simple Scan. The solution posted here: https://ubuntuforums.org/showthread.php?t=2362915&p=13663260#post13663260 solved scanning problem with my Canon Pixma G3411.

I first added this PPA: sudo add-apt-repository ppa:rolfbensch/sane-git and sudo apt-get update

After that I had to install updates through Update Manager. And that's it. Now it works with Simple Scan too.

  • Have a Canon G6050 and this solution solved my problem perfectly
    – Des Magner
    Jan 5, 2021 at 15:18

I had some issues with my 18.04.5 install so I did a fresh install and after it wasn't recognizing my HP All in One Printer (3630) as a scanner. It found it as a printer just fine but every time I tried to scan it said no scanner was attached.

I went to System settings -> Printers -> then "+ add" -> Network Printer -> Find Network Printer -> and there it asked me if I wanted to add the HP printer and search for drivers. I did this, it downloaded the drivers and then the printer appeared as a new (albeit duplicate 3630) printer and when I ran the Simple Scan it recognized the printer and I was able to scan.

Hope that others may be able to use this workaround.


I have all in one Epson printer and I found out there is a scanner drivers for them, So you have to install them for simple-scan to be able to detect.

Epson drivers


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.