0

When I'm trying to install Kodi, I get:

root@xKaganovich:/home/kaganovich# apt-get install kodi
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  fonts-roboto fonts-roboto-hinted kodi-data libcec-platform1v5 libcec3
  libfstrcmp0 libhdhomerun2 libjs-iscroll libsdl2-2.0-0 libsndio6.1
Use 'sudo apt autoremove' to remove them.
Suggested packages:
  kodi-pvr-mythtv kodi-pvr-vuplus kodi-pvr-vdr-vnsi kodi-pvr-njoy
  kodi-pvr-nextpvr kodi-pvr-mediaportal-tvserver kodi-pvr-tvheadend-hts
  kodi-pvr-dvbviewer kodi-pvr-argustv kodi-pvr-iptvsimple
  kodi-audioencoder-vorbis kodi-audioencoder-flac kodi-audioencoder-lame
The following NEW packages will be installed:
  kodi
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/20.0 MB of archives.
After this operation, 37.1 MB of additional disk space will be used.
(Reading database ... 264739 files and directories currently installed.)
Preparing to unpack .../kodi_2%3a17.6+git20171114.2125-final-0xenial_all.deb ...
Unpacking kodi (2:17.6+git20171114.2125-final-0xenial) ...
dpkg: error processing archive /var/cache/apt/archives/kodi_2%3a17.6+git20171114.2125-final-0xenial_all.deb (--unpack):
 trying to overwrite '/usr/share/kodi/media/icon32x32.png', which is also in package kodi-data 15.2+dfsg1-3ubuntu1.1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for menu (2.1.47ubuntu1.16.04.1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/kodi_2%3a17.6+git20171114.2125-final-0xenial_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

How can i fix this problem?

0

You have a file conflict. Two packages are trying to provide the same file, and that's not allowed in a Debian-based system.

The packages kodi 2:17.6+git20171114.2125-final-0xenial and kodi-data 15.2+dfsg1-3ubuntu1.1 conflict. They cannot be installed at the same time. This usually occurs when the packages are from different sources.

There are two ways to resolve the problem.

1) Pick the package you want to keep, uninstall ALL packages from the rejected source, and delete the rejected source. Keeping packages from the rejected source may cause version conflicts or more file conflicts.

2) Use apt's --force flag to agree to overwriting the file. This solves the problem for today, but the problem may re-occur each time the packages are upgraded.

The easy way to prevent this problem is by limiting your non-Ubuntu sources, deleting experimental sources after failed attempts, and occasionally using apt autoremove to clean orphaned packages off your system.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.