23

I have 3 monitors, the left one is 4k, while the other 2 are 1080p. The problem I am having is that if I have the 1080p monitors on normal scaling, the 4k monitor is basically unusable because everything is too small, but if i set the 4k monitor to 200%, gnome automatically changes the scaling of the other 2 monitors and makes them unusable due to everything being too far zoomed in.

What can I do here? Is there anything in gnome tweaks that can fix this?

3
  • 1
    possible duplicate of this question. Anyway, I would try that first- or if you are not comfortable with command line there is gui wrapparound called ARandR
    – sipral
    Commented Oct 15, 2018 at 21:59
  • 1
    @sipral That's a great link but a new user might need a targeted answer. Lanes100-Can you type xrandr | grep connected in the terminal and paste the results into your question? Commented Oct 15, 2018 at 22:43
  • 2
    Possible duplicate of config dual monitors with quite different resolution
    – vanadium
    Commented Oct 16, 2018 at 16:29

3 Answers 3

11

This works fine in my case, using 3k notebook and 1600px monitor with different scale:

  1. Open dconf Editor.
  2. Go to /org/gnome/mutter/experimental-features
  3. Disable "Use default value"
  4. Write custom value: ['scale-monitor-framebuffer', 'x11-randr-fractional-scaling']

Now you can use different scale for each screen in the display settings.

dconf setting capture

Scale 200% in screen 3000x2000px

Scale 100% in secondary screen 1600x900px

Tested in Ubuntu 19.10, GNOME 3.34.2.

5
  • 1
    Please do not post the same answer many times to different questions. If the questions are similar enough that they all have the same answers, consider flagging the questions as duplicates of one of the questions, rather than reposting the same answer many times.
    – Thomas Ward
    Commented Dec 10, 2019 at 14:45
  • hi, ok i new here, reviewing your suggest. thanks
    – hkcoyant
    Commented Dec 10, 2019 at 19:39
  • This approach doesn't work on Debian 10 using gnome Commented Mar 2, 2020 at 15:11
  • look for the gnome version i'm using 3.34.2
    – hkcoyant
    Commented Mar 3, 2020 at 17:05
  • Same as gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer', 'x11-randr-fractional-scaling']". Did you notice any performance issue? Commented Jan 12, 2023 at 4:10
8

I turned on "fractional scaling" in Settings/Displays and it now lets me set different scaling factors for the different displays. Hooray! I was afraid that I wouldn't be able to use my external monitor with my new laptop.

7
  • Holy tomato, that's the answer to the ultimate goal for over a decade!! Thank you!! Pop_OS 21.10 (aka Ubuntu 21.10), 4k laptop and tri-monitor 1080p 24" screens.
    – eduncan911
    Commented Jan 2, 2022 at 5:28
  • The option says May increase power usage, lower speed, or reduce display sharpness. You didn't note any of these? Which version of Ubuntu/GNOME do you have? Commented Jan 12, 2023 at 4:01
  • Nope, no such issues were noticed, but I'm not paying attention to the power usage. Commented Jan 13, 2023 at 20:54
  • Oh, sorry, that laptop bricked itself awhile back, and it's been replaced, and the replacement has been upgraded, so I've lost track of the version. Commented Jan 13, 2023 at 20:55
  • 1
    This was what I needed on Ubuntu 22.10.
    – Cliff
    Commented Apr 22, 2023 at 20:58
3

If someone is looking for help with this in 2020 or later, probably the solution is to change your session to use wayland instead of xorg. It depends on your distro but you usually can choose what kind of session you want before logging in into your session. You should see some kind of cog icon and you should choose something like "GNOME on Wayland" or "GNOME" if there is some other option which says anything about xorg.

Please be aware that some apps might not change their scale when you move them from one screen to the other.

3
  • Yeah, I'm on a laptop with a GPU and it reboots when i plug an external monitor in and try Wayland ;(
    – CpILL
    Commented Nov 3, 2021 at 19:45
  • 1
    you do not need wayland for this. X support this long time ago. If you want GUI to support it just do what @stolenmoment suggested: turn on fractional scaling
    – Wang
    Commented Nov 28, 2022 at 17:48
  • @Wang Great advice and all, but there’s simply no option to turn on fractional scaling in Arch Linux Ghome on Xorg. And I can’t use Gnome on Wayland becausae global hotkeys aren’t supported and I can’t screencast or screen record... Commented May 30 at 3:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .