1

I am trying to install Dragonfly on Ubuntu 14.04. After working out several other issues with the installation, I am now dealing with the problem that I need to get libsystemd.so.0. Based both on the name and on threads from other help communities, I thought I would get it if I installed systemd. However, that does not seem to be the case. I ran sudo updatedb and then locate libsystemd.so.0 and it returned nothing. Is there a step I am missing or did I install the completely wrong package?


Edit:

I just ended up installing on a Windows instead. Would have been nice if the docs told you 14.04 and earlier aren't supported. All it says is you need 64-bit Linux.

  • 1
    No official package provides that file for 14.04: packages.ubuntu.com/… – muru Oct 16 '18 at 1:48
  • @muru So is there some unofficial way to get it then? The software won't run without the package. – Andrew Shum Oct 16 '18 at 17:49
1

Ubuntu 14.04 LTS ships systemd 204, which is a fairly old version or systemd.

That version did already have a separate library akin to libsystemd.so.0, only it was called libsystemd-daemon.so.0.

You can try to install the development files for it (apt-get install libsystemd-daemon-dev) and either adapt Dragonfly to try to link against that library, or maybe even try something more hacky and create a symlink libsystemd.so pointing to the existing libsystemd-daemon.so in your lib directory, maybe Dragonfly will build and work that way, but at this point you have basically "voided the warranty", so even if this works, I wouldn't really recommend it.

If you have a chance to use more recent versions of Ubuntu instead, such as 16.04 LTS or 18.04 LTS, both of those ship more modern versions of systemd which include libsystemd.so.0, so I'd expect they'd work fine with the software you're trying to use. If using one of those is an option for you, I'd recommend going that route.

| improve this answer | |
  • Thanks for the answer. I would prefer not to have to change Ubuntu versions but I definitely don't want to "void the warranty" as you put it. Its too bad you can't just copy libsystemd.so.0 and have it work. – Andrew Shum Oct 23 '18 at 22:50
  • Since installing system didn't help, is it safe to uninstall it? – Andrew Shum Nov 8 '18 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.