After completing an Ubuntu automatic software update (15 Oct 2018) that included Thunderbird 60.2.1 the Lightning calendar is now missing. When I click on Thunderbird's Add-On tab to see if there's an update for Lightning I'm told that all the versions of Lightning available there are not compatible with the updated Thunderbird release. All my calendar data is no longer available to me - HELP!!

up vote 132 down vote
+50

Same here, on (Ubuntu based) Linux Mint 19. It seems to be a thunderbird issue but the update should not have been passed through when it breaks what many regard as core functionality.

A solution is posted on the Linux Mint forums:

I ran into this problem today in Mint 19 when Tbird 60.2.1 was installed through the Update Manager. Removing the Lightning add-on from Tbird and installing the "xul-ext-lightning" package allowed me to recreate my calendar and connect it to Google Calendar.

So the solution is:

  1. remove the lightning add-on in Thunderbird;
  2. exit from Thunderbird;
  3. install xul-ext-lightning package with

    sudo apt install xul-ext-lightning
    

    (it will pull more packages in).

  4. restart Thunderbird.

My previous settings had been retained and I did not need to recreate my calendar.

If calendar tab is missing: watch out for the mini "switch to calendar tab" icon on the very right of tab bar: switch to calendar on TB 60+

If still you can't see any calendar, try (after following steps 1...4 above) to follow the instructions in this calendar troubleshooting article published on the Thunderbird Release Notes.

NOTICE that this seems to fail if the calendar is configured with a language different from English. There is an extended discussion, with links to bug reports, on the mozilla help forums.

  • 2
    Probably it's more a packaging issue than a thunderbird problem. They passed to bundle lightining from version 38, it seems... support.mozilla.org/en-US/kb/… – Rmano Oct 16 at 8:02
  • 1
    The release notes for this version of Thunderbird had a link to a calendar troubleshooting article that was supposed to address this issue. It did not work, but the instructions here fixed it right up. I'm on LinuxMint 18.3 x86_64 – Matthew Oct 16 at 13:58
  • 2
    Worked fine for me on stock Ubuntu 18.04. Before installing, I used apt policy xul-ext-lightning to check that the version about to be installed (1:60.2.1+build1-0ubuntu0.18.04.2 at time of writing) was in-line with the TB version... – sxc731 Oct 16 at 18:00
  • 3
    On Ubuntu 18.04, I had to first remove the plugin Lightning from Thunderbird, then install it using APT. Then it's working. It was not working when the previous plugin version was in Thunderbird. – Gustry Oct 17 at 12:47
  • 3
    @Gustry --- it's written quite clearly in the answer, I think... step 1. ;-) – Rmano Oct 17 at 12:56

I did not try xul-ext-lightning package but the following solution worked for Thunderbird 60.2.1 on Ubuntu 18.04:

  1. Go to https://archive.mozilla.org/pub/thunderbird/releases/60.2.1/linux-x86_64/ (or i686 for 32-bit)
  2. Click the link for your language (I picked en_GB)
  3. Download thunderbird-60.2.1.tar.bz2
  4. Open the archive.
  5. Navigate to /thunderbird/distribution/extensions/
  6. Extract {e2fda1a4-762b-4020-b5ad-a41df1933103}.xpi (This is the Lightning extension)
  7. Drag it from wherever it was extracted to onto the Thunderbird Add-ons manager.
  8. Lightning should install.

All the previous settings are retained and lightning is updated to version 6.2.2.1

Thanks to reddit user palordrolap for the solution (written for Linux Mint 17.3).

  • 5
    Yes, it would work, but I am not sure that, this way, you'll have the sync update of TB and the lightning extension next time there is an update. Most probably not... – Rmano Oct 16 at 10:43
  • 3
    @Rosika yes, but the next update to TB, you will have to re-do the thing for lightning --- it's no more in the "add-ons cloud", so the auto-update will not trigger. While if you install xul-ext-lightning (which will provide exactly the same file for now) I suppose that when TB is updated, Ubuntu will take care to update also xul-ext-lightning. Disclaimer: this is a guess --- based on my partial understanding of the matter. – Rmano Oct 16 at 15:09
  • 1
    @Rmano: Tnx for the info. xul-ext-lightning didn´t work with me. Still no lightning. But the extraction-and-dragging-it-over-method did the job. Greetings. – Rosika Oct 16 at 16:28
  • 1
    @Rosika @Zeta sadly lightning will definitively NOT get automatic updates (via addon-manager), as you can proof it by having a look at your profile (resp. backup) before fiddling around: your lightning-version will be 5.4 because it is the latest version published via the addon-site, although you can easily verify here, that the latest <60-compartible version is 5.4.9.1. - so you already missed a bunch of updates in the last ~1,5 years. – DJCrashdummy Oct 18 at 12:56
  • 1
    @FairMiles @Rmano although this is a really bad practice by mozilla and i see no reason why to stop publishing lightning via addon. but it is ubuntu whose packages are "broken" and need to be fixed, because on debian there are lang-packs for linghtning (lightning-l10n-...) and so this in hardly a topic there. – DJCrashdummy Oct 18 at 13:06

You can install the Lightning beta extension from xpi file for Thunderbird 60. You can download the latest Lightning here.

Source: https://www.reddit.com/r/Thunderbird/comments/9gt80n/lightning_does_not_work_on_thunderbird_60/

This worked for me perfectly. Mint 17.2 64 bit

  • 1
    Worked for me & is probably the easiest solution... Will this update when it comes out of beta? – joris Oct 29 at 12:20
  • I am not sure. But will work even on Windows... – kukulo Oct 29 at 16:08
  • Thanks for that post. You saved my day! Worked great unter ubuntu 18.04 with TB 60.2.1 – Daniel Oct 29 at 21:18

protected by Community Oct 16 at 19:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.