1

I help manage a small fleet of thinkpads with Xubuntu 16.04 that are used for giving workshops.

When a user attaches a USB key, I need Thunar to automount the USB with read and write permissions for that user (non-root). Presently, it is automounting as read only. I've tried at least 3 different usb keys. They all show lock icons on files inside the usb key.

Basically, I need the participants of our workshops to be able to plug their USB key and “drag and drop” files from a local folder into their USB key.

Edit: I've tried this using 3 different usb keys in 3 different file systems (ntfs, ext4, and fat32) and results were the same.

Interestingly, if in Thunar, I select the file: right click -> Send to -> usb , it works as intended.

The challenge is that most of our workshops participants are children who are learning to use computers, so the less steps, and the more intuitive the better. That's why I really would like to get drag and drop to work.

Gif illustrating problem above

1

From your GIF, when you drag files to the USB key Thunar is trying to create a shortcut in the Places sidebar because it's in Shorcuts view.

I can reproduce this on Xubuntu 18.04 with my external HDD (Thunar 1.6.15/Xfce 4.12). At the moment, this is the expected behavior when dragging files to the sidebar using that view.

The fact that right click > Send to > usb works means that the filesystem on the usb key is owned by your user.

Answer

In the Thunar window go to View → Side Pane → Tree window or press CTRL + E to switch the side panel to Tree View, then drag your files to the usb key.

Source: xfce.org - File Manager Window

Alternative Method

Use 2 Thunar windows side by side, one of them pointed to /media/<username>/<USB key label>/ (the default mount location in Xubuntu) and the other pointed to the folder where your files are, then drag your files from one window to the other and it should work.

  • 1
    Switching the side-pane to tree-view might also work. – mook765 Oct 25 '18 at 13:39
  • @mook765 You're totally right and that's closer to what op wants. – Marco R. Oct 25 '18 at 14:16
  • Thank you very much @mook765 ! The tree view suggestion has solved my user-case problem! – MauQc Nov 24 '18 at 14:40
1

It seems to be a problem with Thunar's Volume Manager.

When I have the Volume Manager enabled and plug in a pendrive, it's mount-point is owned by root and I can't access the files. When I disable the Volume Manager and mount the pendrive manually via right-click, the mount-point is owned by me and I can access the files or create new files.

I'm not sure if this is intended behavior or if it is a bug, I couldn't find a bug-report.

As a work-around you can use the following steps to disable Thunar's Volume Manager and mount the pendrives manually, it shouldn't be too inconvenient.

Unmount and remove the pendrive from the system. In Thunar go to

Edit > Preferences > Advanced Tab

and untick the corresponding checkbox. Close Thunar and open Thunar again. When you plug in the pendrive now, it will be listed in the left pane, but isn't mounted. Right-click the drive and select Mount. You should be able to drag and drop files now.

  • I've tried this but it didn't change anything. Thanks a lot for the suggestion tho. – MauQc Oct 23 '18 at 1:46
0

This thread over at the superuser stack exchange and this one at the Unix & Linux SE have some recommendations on troubleshooting and possible solutions.

One thing that could help is adding an entry to your /etc/fstab that specifies the correct uid and gid. Suppose that your normal user's uid and gid are both 1000 (which I think is the default), that your USB key is formatted in FAT and that your USB key is /dev/sdb1, then this fstab entry may accomplish what you are looking for: /dev/sdb1 /path/to/mountpoint/ vfat user,auto,rw,nofail,async,uid=1000,gid=1000,noatime 0 0

Adding an extra entry fstab shouldn't be necessary, though, so it might be a better idea to go through your Thunar preferences and the related packages as suggested by the threads above.

  • Unfortunately after I've added the entry you suggested Thunar stopped showing the USBs on the Devices column. The additional challenge is that although the user's USB will probably be formatted in fat32 or ntfs, I cannot be sure. I've added more information to the post in hopes it helps. Thanks for the suggestions. – MauQc Oct 23 '18 at 1:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.