9

Clean installation of Ubuntu 18.10 beta

I want the screen to turn off after 1 minute of inactivity, but I do not want the system to be locked when it is activated again. So I do :

gsettings set org.gnome.desktop.session idle-delay 60
gsettings set org.gnome.desktop.screensaver lock-enabled false

The screen turns off after 1 minute of inactivity. The problem is that after that when I try to access the system it is stuck at a purple screen similar to the one of the lock screen but with no input form for password. The only way to access the system, is to suspend the system and then resume.

Do you have any view on this?

0

I was also experiencing this, and found that it was due to a Gnome Shell Extension.

My experience is that logging in initially was fine. Logging out and logging back in was fine, but resuming from a 'lock' status was causing the issue. I simply could not get the 'shade' to swipe up to reveal the password input. No swipes on the trackpad, mouse, or keyboard presses would reveal the input.

Try disabling all extensions and then logging out (not just locking) so that your session is restarted.

After that you can go in and start enabling extensions one at a time, log out, log back in, then lock (super + l). If you can't log in, the last extension you enabled is the culprit and you'll have to either way for an update to be compatible, and it'd be super awesome if you go let the extension developer know on the extensions.gnome.org page.

  • 1
    To recover from the "broken lock-screen", I can press super + L and then get to the proper lockscreen. – stebu92 Jan 7 at 12:50
6

Same here after upgrading from 18.04 to 18.10. First tried to disable my extensions. After about an hour working I tried to lock my machine and failed. So not a solution for me.

Googling some more, when I came across Lock screen curtain in Ubuntu 18.10 won't open and a suggestion there was to remove and add gdm3 from terminal:

$ sudo apt remove gdm3
$ sudo apt install gdm3 
$ reboot

Now, half a day working later, 10+ locks, the issue has not returned.

Update 2018-11-16

Issues have returned unfortunately. After going through the bugreport this suggestion came by:

gsettings set org.gnome.shell.extensions.dash-to-dock transparency-mode FIXED

For me this seems to work.

  • 1
    I've been fighting this one for a while, and the gsettings change worked for me. Thanks! – William MacDonald Dec 11 '18 at 15:50
0

In my case, the isue is a bit different. I have 4 extensions installed : Auto Move Windows, Gsconnect (from Github), KstatusnotifierItem and Openweather.

All is fine for several days, then suddenly I face the purple screen after black screen timeout. I can then press "Super-l" then "Esc" keys to login again... But then ALL extensions are disabled. So I reboot, and all extensions are back again.

Looks like a bug in 18.10, got no such issue with 18.04.

  • Did you file or find a related bug? – localhost Nov 9 '18 at 8:59
  • No, found (and filled) nothing... I will investigate a bit further, as this is really annoying. One more thing I noticed is that all icons in the top bar has disappeared when logging back. Will deactivate things one by one and see how it goes. Checking also logs with "sudo journalctl -f /usr/bin/gnome-shell". – pled Nov 10 '18 at 14:36
  • Perhaps it is related to bugs.launchpad.net/ubuntu/+source/… – localhost Nov 11 '18 at 10:27
  • Yes, it looks like similar, at least related to that problem. Anyway, since I have disabled "KStatusNotifierItem/AppIndicator Support" extension, issue has disappeared... – pled Nov 15 '18 at 8:41
  • Correction : KStatusNotifierItem/AppIndicator Support" extension disabled seems only to reduce occurence of the issue... :-( – pled Nov 17 '18 at 14:59
0

First, install dconf-editor:

sudo apt install dconf-editor

After, start dconf-editor and open path /org/gnome/desktop/lockdown/

Make sure, option disable-lock-screen is disabled.

The same with gsettings:

gsettings set org.gnome.desktop.lockdown disable-lock-screen false
  • 2
    How is this related to the question? – localhost Jan 10 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.