80

I already knew that Ctrl+Shift+u would allow to type a character by giving its Unicode hexadecimal representation: an underlined u appears, you type the code and hit Enter.

For example, Ctrl+Shift+u; e; 9; Enter gives the character é.

Now I've just noticed that Ctrl+Shift+e lets an underline e appear, in a very similar manner, but I can't figure out what it does.

Does someone know? Thank you in advance.

2
  • I am using the French keyboard layout from Switzerland, but sometimes also the Swedish one from Sweden. I don't think it is relevant though. Oct 15, 2018 at 12:24
  • 3
    Two years later: Did Ubuntu just remove that feature? Dec 8, 2020 at 10:31

3 Answers 3

78

Ctrl+Shift+e is the emoji entry shortcut/hotkey sequence.

It produces an underlined "e̲", if you type "joy" after it (so it looks like "e̲j̲o̲y̲") the whole word will be underlined. On pressing a whitespace entry key, like spacebar, you should then get the "e̲j̲o̲y̲" text changed to "😂" (the emoji character selected by your current application). 👍

8
  • 1
    I think you can adapt this to a separate answer to this question too.
    – pomsky
    Oct 16, 2018 at 10:52
  • 4
    I can't find a list of codes anywhere, happened on the "joy" one. Apparently the emojis are based on EmojiOne and I thought based on that linked page that the shortcode without the separators would be the entry code, but only "joy", "kiss" and "like" works for me. "grinning", "smile", "frown", "sad", "couplekiss" etc. as modifiers after the shortcut don't work, they give no entry. Links from bugs show you can disable it with ibus-setup, but I don't have ibus installed on my Kubuntu.
    – pbhj
    Oct 16, 2018 at 22:45
  • 2
    I think simple simple emoticons (e.g. :) :( :p :D etc.) may work, please try them. I don't have a 18.04 installation with me right now.
    – pomsky
    Oct 16, 2018 at 22:49
  • 25
    Thank you! Now can we disable it? 😂 It conflicts with IDEA/Android Studio's shortcut for Recently Changed Files.
    – Peter
    Jun 14, 2019 at 3:36
  • 2
    @Peter You can disable it by launching IBus Preferences -> Emoji tab -> Emoji Annotation -> ... -> Delete key forums.opensuse.org/showthread.php/….
    – CoredusK
    Aug 10, 2021 at 9:31
68

Just issue the command bellow:

ibus-setup

And change it on the Emoji tab as the picture bellow

IBus Preferences Window

8
  • 12
    I've modified the emoji annotation shortcut as suggested here, and it seems to work in e.g. gedit and LibreOffice Writer, but for some reason the emoji annotation is still activated by Ctrl+Shift+e in Visual Studio Code. Does anyone know why?
    – Liam Baker
    Jan 27, 2020 at 13:40
  • 2
    @LiamBaker I have the same issue, have you found any solution? Apr 30, 2020 at 3:59
  • From my research, it seemed to be because I'm using the snap version of VSCode, which may include an old version of GTK which still has this behaviour (the 'feature' was removed in GTK 3.24, I believe). Apparently it is fixed if one installs the apt/deb version instead, although I haven't tried this yet; let me know if that works for you!
    – Liam Baker
    Apr 30, 2020 at 11:24
  • @LiamBaker Since ctrl+shift+e usecase in vscode is to open explorer, my solution was to change the combo to ctrl+e. (or alternative is ctrl+p): ``` { "key": "ctrl+e", "command": "workbench.view.explorer" }, { "key": "ctrl+shift+e", "command": "-workbench.view.explorer" }, { "key": "ctrl+shift+e", "command": "-workbench.action.quickOpenNavigatePreviousInFilePicker", "when": "inFilesPicker && inQuickOpen" } ```
    – ego
    Jul 16, 2020 at 10:12
  • 8
    If you installed VS Code using Snap, here how to disable the combination: askubuntu.com/a/1269239/229740
    – zardosht
    Aug 22, 2020 at 15:57
1

Based on other answers here, I discovered that this keyboard shortcut defaults to Ctrl+. for anyone running Ubuntu with the KDE desktop environment.

Typing this shortcut displays the same "underlined e" character in a text box and doesn't seem to want to disappear unless I type some additional characters after it and hit Enter. Then it just leaves me with the additional characters I typed.

the "underlined e" character displayed after pressing this shortcut

using the ibus-setup command, I was able to confirm that, on my system, this emoji entry shortcut was set to <Control>period which I found myself accidentally hitting occasionally. Changing it to Ctrl + Shift + e will likely make this a lot less likely for me to accidentally activate

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.