1

After running into this bug: https://gitlab.gnome.org/GNOME/gnome-control-center/issues/236

I can't get my locale fixed. It is impossible to fix it with gnome-control-center, and "export LANGUAGE=gd:en_GB:en" will fix it in the current terminal only.

I have read https://help.ubuntu.com/community/EnvironmentVariables#Persistent_environment_variables

Also,

$ cat /etc/default/locale
LANGUAGE="gd:de_DE:en_GB:en"
LC_NUMERIC="gd_GB.UTF-8"
LC_TIME="gd_GB.UTF-8"
LC_MONETARY="gd_GB.UTF-8"
LC_PAPER="gd_GB.UTF-8"
LC_IDENTIFICATION="gd_GB.UTF-8"
LC_NAME="gd_GB.UTF-8"
LC_ADDRESS="gd_GB.UTF-8"
LC_TELEPHONE="gd_GB.UTF-8"
LC_MEASUREMENT="gd_GB.UTF-8"
LANG="gd_GB.UTF-8"

but when I log in again and start a terminal, de_DE is back like a bad penny.

I have edited /etc/common/locale as suggested, and this file is now clean, but the locale setting regressed. Regerating the locales has no effect, because the locales athemselves are not broken. Programs are still using German, and it's listed in the terminal. A reboot after applying the changes has no effect.

$ cat /etc/default/locale
LANGUAGE=gd:en_GB:en
LC_NUMERIC="gd_GB.UTF-8"
LC_TIME="gd_GB.UTF-8"
LC_MONETARY="gd_GB.UTF-8"
LC_PAPER="gd_GB.UTF-8"
LC_IDENTIFICATION="gd_GB.UTF-8"
LC_NAME="gd_GB.UTF-8"
LC_ADDRESS="gd_GB.UTF-8"
LC_TELEPHONE="gd_GB.UTF-8"
LC_MEASUREMENT="gd_GB.UTF-8"
LANG="gd_GB.UTF-8"

$ locale
LANG=gd_GB.UTF-8
LANGUAGE=gd:de_DE:en_GB:en
<snip>

$ sudo locale-gen "en_US.UTF-8"
Generating locales (this might take a while)...
  en_US.UTF-8... done
Generation complete.

$ sudo dpkg-reconfigure locales
Generating locales (this might take a while)...
  en_AG.UTF-8... done
<snip>
  en_ZW.UTF-8... done
  gd_GB.UTF-8... done
Generation complete.

$ locale
LANG=gd_GB.UTF-8
LANGUAGE=gd:de_DE:en_GB:en
LC_CTYPE="gd_GB.UTF-8"
LC_NUMERIC=gd_GB.UTF-8
LC_TIME=gd_GB.UTF-8
LC_COLLATE="gd_GB.UTF-8"
LC_MONETARY=gd_GB.UTF-8
LC_MESSAGES="gd_GB.UTF-8"
LC_PAPER=gd_GB.UTF-8
LC_NAME=gd_GB.UTF-8
LC_ADDRESS=gd_GB.UTF-8
LC_TELEPHONE=gd_GB.UTF-8
LC_MEASUREMENT=gd_GB.UTF-8
LC_IDENTIFICATION=gd_GB.UTF-8
LC_ALL=
0

Did you try reconfigure? if not, then try this -

sudo locale-gen “en_US.UTF-8”
sudo dpkg-reconfigure locales
  • No effect, probably because the locales were never broken. This will not fix a superfluous locale listed in LANGUAGES. – GunChleoc Oct 20 '18 at 7:42
0

You can update /etc/default/locale manually like this:

sudo update-locale LANGUAGE=gd:en_GB:en
  • Thanks that fixed it! I now have to go into the language settings pf each application manually, because they're still stuck, but it's at least doable now. Note that this will regress everytime I manage the language in settings and appply system.wide. – GunChleoc Oct 17 '18 at 9:28
  • @GunChleoc: Well, yes. It's about the logic applied for managing the LANGUAGE priority list when changing display language. That code does not take deletion of previously selected languages into consideration, but guesses that they should be included in the list. But you can manage the list as you wish from the Language tab in gnome-language-selector. – Gunnar Hjalmarsson Oct 17 '18 at 14:03
  • The problem is still there - see my update to the question. – GunChleoc Oct 20 '18 at 7:42
  • @GunChleoc: Saw it, and saw your own answer. Can confirm that both those files are involved. The GUI way to deal with it is the Language tab in Language Support. – Gunnar Hjalmarsson Oct 20 '18 at 11:48
0

grep to the rescue - the following 2 files need to be edited with sudo gedit to remove the locale:

/etc/default/locale
/home/<user>/.pam_environment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.