0

I am using Ubuntu 18.04. It is having the following update issue when running sudo apt update and sudo apt upgrade

Hit:14 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease      
Fetched 83.2 kB in 4s (23.0 kB/s)                                             
Reading package lists... Done
Building dependency tree       
Reading state information... Done
2 packages can be upgraded. Run 'apt list --upgradable' to see them.

Results of sudo apt list --upgradable :

Listing... Done
nodejs/bionic-updates 8.10.0~dfsg-2ubuntu0.3 amd64 [upgradable from: 8.10.0~dfsg-2ubuntu0.2]
nodejs-dev/bionic-updates 8.10.0~dfsg-2ubuntu0.3 amd64 [upgradable from: 8.10.0~dfsg-2ubuntu0.2]

Results of sudo apt upgrade :

sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libasan3-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libasan4-armel-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libasan4-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libatomic1-armel-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libatomic1-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libc6-armel-armhf-cross : Depends: libc6-armel-cross but it is not installed
 libc6-armhf-armel-cross : Depends: libc6-armhf-cross but it is not installed
 libc6-dev-armel-armhf-cross : Depends: libc6-dev-armel-cross but it is not installed
 libcilkrts5-armel-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libcilkrts5-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libgcc1-armel-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libgcc1-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libgomp1-armel-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libgomp1-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libhfasan4-armel-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libhfatomic1-armel-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libhfcilkrts5-armel-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libhfgomp1-armel-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libhfstdc++6-armel-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libhfubsan0-armel-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libsfasan4-armhf-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libsfatomic1-armhf-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libsfcilkrts5-armhf-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libsfgomp1-armhf-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libsfstdc++6-armhf-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libsfubsan0-armhf-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libstdc++6-armel-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libstdc++6-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
 libubsan0-armel-cross : Depends: libc6-armel-cross (>= 2.27) but it is not installed
 libubsan0-armhf-cross : Depends: libc6-armhf-cross (>= 2.27) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Results of sudo apt --fix-broken install :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  cpp-7-arm-linux-gnueabi cpp-arm-linux-gnueabi gcc-7-arm-linux-gnueabi gcc-7-arm-linux-gnueabi-base gcc-arm-linux-gnueabi libasan4-armel-cross libatomic1-armel-cross libc6-armhf-armel-cross libcilkrts5-armel-cross
  libgcc-7-dev-armel-cross libhfasan4-armel-cross libhfatomic1-armel-cross libhfcilkrts5-armel-cross libhfgcc-7-dev-armel-cross libhfgcc1-armel-cross libhfgomp1-armel-cross libhfstdc++6-armel-cross
  libhfubsan0-armel-cross libstdc++6-armel-cross libubsan0-armel-cross
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libc6-armel-cross libc6-armhf-cross libc6-dev-armel-cross
The following NEW packages will be installed:
  libc6-armel-cross libc6-armhf-cross libc6-dev-armel-cross
0 upgraded, 3 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B/3,972 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 
(Reading database ... 424757 files and directories currently installed.)
Preparing to unpack .../libc6-armel-cross_2.27-3ubuntu1cross1.1_all.deb ...
Unpacking libc6-armel-cross (2.27-3ubuntu1cross1.1) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-armel-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack):
 unable to open '/usr/arm-linux-gnueabi/lib/ld-2.27.so.dpkg-new': No such file or directory
No apport report written because the error message indicates an issue on the local system
                                                                                         Preparing to unpack .../libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb ...
Unpacking libc6-armhf-cross (2.27-3ubuntu1cross1.1) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack):
 unable to open '/usr/arm-linux-gnueabihf/lib/ld-2.27.so.dpkg-new': No such file or directory
No apport report written because the error message indicates an issue on the local system
                                                                                         Preparing to unpack .../libc6-dev-armel-cross_2.27-3ubuntu1cross1.1_all.deb ...
Unpacking libc6-dev-armel-cross (2.27-3ubuntu1cross1.1) ...
dpkg: error processing archive /var/cache/apt/archives/libc6-dev-armel-cross_2.27-3ubuntu1cross1.1_all.deb (--unpack):
 unable to open '/usr/arm-linux-gnueabi/lib/Mcrt1.o.dpkg-new': No such file or directory
No apport report written because the error message indicates an issue on the local system
                                                                                         Errors were encountered while processing:
 /var/cache/apt/archives/libc6-armel-cross_2.27-3ubuntu1cross1.1_all.deb
 /var/cache/apt/archives/libc6-armhf-cross_2.27-3ubuntu1cross1.1_all.deb
 /var/cache/apt/archives/libc6-dev-armel-cross_2.27-3ubuntu1cross1.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • Try to apt -f install – Steagee Oct 15 '18 at 9:47
  • Hi, i tried that. It throughs the same error as above. – Rahul Sharma Oct 16 '18 at 7:14
  • Try to remove this problem package and reinstall in manualy: apt purge libc6-dev-armel-cross Download this package from here: https://packages.debian.org/sid/libc6-dev-armel-cross Then dpkg -i libc6-dev-armel-cross_2.27-6cross1_all.deb And try to apt update && apt upgrade again – Steagee Oct 16 '18 at 8:32
  • Hi, thanks for reply. I did the same again, initially it was not installing then i intall it with "ignore-depends flag". After installing, the apt upgrade is giving the same error for "apt --fix-broken install" – Rahul Sharma Oct 16 '18 at 8:45
  • 1
    Hi, just wanted to tell that after "ibc6-dev" installation that you suggested, i did "-f dist-upgrade". And finally its done. Nothing was giving result only this command gave result. – Rahul Sharma Oct 16 '18 at 10:29
0

Had the same problem with Mcrt1.o.dpkg-new and the only working solution was to remove all packages with dependency problems together. In my case the list was:

apt remove libc6-dev-armel-cross libstdc++-7-dev-armel-cross libstdc++-5-dev-armel-cross g++-5-arm-linux-gnueabi  g++-7-arm-linux-gnueabi g++-arm-linux-gnueabi libasan2-armel-cross  libasan4-armel-cross libatomic1-armel-cross libcilkrts5-armel-cross libgcc1-armel-cross libgomp1-armel-cross libstdc++6-armel-cross libubsan0-armel-cross libgcc-5-dev-armel-cross libgcc-7-dev-armel-cross gcc-5-arm-linux-gnueabi gcc-7-arm-linux-gnueabi  gcc-arm-linux-gnueabi

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.