3

Problem

Nautilus hides hidden files on reboot regardless of setting before rebooting.

Expected

Nautilus keeps "show hidden" setting from before shutdown (in my case, always showing hidden files regardless of setting before shutdown is ok too).

Question

How to have Nautilus show hidden files after reboot without manually enabling "show hidden files" each time?

Debug info

{reboot}
$ gsettings get org.gnome.nautilus.preferences show-hidden-files
true

Open Nautilus (icon on dash) - hidden files not shown in Nautilus

Control+H - hidden files shown in Nautilus

Close Nautilus window

Open Nautilus (icon on dash) - hidden files not shown in Nautilus (expected behaviour)

Nautilus --> Edit --> Preferences --> Show hidden and backup files

Hidden files now shown until reboot

Reboot

Open Nautilus (icon on dash) - hidden files not shown in Nautilus

  • Are you sure that permissions are OK for your dot-folders? If unsure - run sudo chown -R $USER:$USER /home/$USER/.*. – N0rbert Oct 14 '18 at 21:41
  • Rather than using gsettings how about using Nautilus Edit Preferences menu for Show hidden and backup files option? Perhaps Nautilus has it's own configuration file. – WinEunuuchs2Unix Oct 14 '18 at 22:29
  • @N0rbert I will test Vijay's answer first and then try your suggestion. Won't your command turn default root-owned directories like ~/.gvfs to be owned by me? Will that cause further problems? – tfstwbbnb Oct 14 '18 at 23:00
  • @WinEunuuchs2Unix Sorry I was not clear. I have tried Nautilus --> Edit --> Preferences --> Show hidden and backup files (using Nautilus Edit Preferences menu). The changes persist until reboot. – tfstwbbnb Oct 14 '18 at 23:00
  • @tfstwbbnb Sorry I missed that. Before trying N0bert's comment first see if any files are owned by root in your home with sudo find /home/$USER -user root – WinEunuuchs2Unix Oct 14 '18 at 23:04
2

In addition to the gsettings key in the post, check if

gsettings get org.gtk.Settings.FileChooser show-hidden

is false.

If it is false, run

gsettings set org.gtk.Settings.FileChooser show-hidden true
  • 1
    I wonder how/why the value had been changed on my machine. It was working properly before. Running gsettings set org.gtk.Settings.FileChooser show-hidden true once allowed my "show hidden" to persist. – tfstwbbnb Oct 16 '18 at 2:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.