1

I have two programs that I've used successfully on Ubuntu for some years - Moneydance and PDF Studio Neither of these programs will install or run under Ubuntu 18.04 on my computer. All I get from the developers is "Well, it works over here", which doesn't give me much to go on.

I don't really know much about Java under the hood, but I understand that these programs are written in Java. I have made an unsuccessful attempt to reinstall Java, but I really didn't understand much of what was going on, and suspect I just re-installed whatever default came with Ubuntu 18.04. When I tried to follow instructions to re-install it, it swiftly led into weeds that I didn't understand and probably didn't execute properly. Ubuntu 18.04 was a fresh install (not an upgrade) as of last July.

Tax time is looming, and I run a small business so it is imperative I get Moneydance running before the end of the year, it is integral to my process for keeping track of business expenses.

Currently, Moneydance is "installed" via .deb download and through the Ubuntu Software application, however picking the program (I'm using Gnome) results in no response. When I return to Ubuntu Software, and search for Moneydance, it claims this program is not installed. [EDIT] Typing the command /bin/sh "/opt/Moneydance/Moneydance" in a terminal results in a stuck cursor with no further output until Cntrl-C. I've tried to reinstall PDFStudio with no luck. Their tech support was stumped.

I have some notes that I apparently tried to install sun jre as follows:

sudo add-apt-repository http://archive.canonical.com/dists/lucid/partner/

Update the source list

sudo apt-get update

Now install sun java packages using the following commands

sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

Enter the following command and when prompted set the sun jre as the default.

sudo update-alternatives --config java

The results were the same.

[EDIT] Currently here is the version of Java that I have installed:

~$ java -version
openjdk version "10.0.2" 2018-07-17
OpenJDK Runtime Environment (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.2)
OpenJDK 64-Bit Server VM (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.2, mixed mode)

[EDIT] I tried this with no effect:

sudo update-alternatives --config java

There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                         Priority   
Status
 ------------------------------------------------------------
  0            /usr/lib/jvm/java-11-openjdk-amd64/bin/java   1101      
 auto mode
* 1            /usr/lib/jvm/java-11-openjdk-amd64/bin/java   1101      
manual mode
  2            /usr/lib/jvm/java-8-oracle/jre/bin/java       1081      

Picked option 2 to go to oracle Java 8 but no changes in results.

[EDIT] Installing PDFStudio gives the following errors:

sh ./PDFStudio_linux64.sh
Unpacking JRE ...
Starting Installer ...
sun.java2d.InvalidPipeException: Unsupported bit depth: 30
at 
sun.java2d.x11.X11SurfaceData.getSurfaceType(X11SurfaceData.java:611)
at 
 sun.java2d.x11.X11SurfaceData.getSurfaceType(X11SurfaceData.java:516)
at 
 sun.awt.X11GraphicsConfig.getSurfaceType(X11GraphicsConfig.java:178)
at sun.java2d.xr.XRSurfaceData.createData(XRSurfaceData.java:235)
at 

sun.java2d.xr.XRGraphicsConfig.createSurfaceData(XRGraphicsConfig.java:45)

.... and a lot of others in the same list.

Running down this rabbit hole, I found out that there was some problem with Nvidia drivers and unsupported bit depth 30. (I say "some problem" because i didn't understand anything else since the rest of the discussion was way above my pay grade. ) Apparently this may relate to a known bug in Java, but I can't decipher anything else they are talking about.

I've been having some unrelated issues after upgrading to an Nvidia GT1030 graphics card, so I downgraded back to the old Nvidia NVS 300 and Nvidia driver 340 that was in this system before. 340 is the latest driver for this legacy card. No luck in any department, still having these Java issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.