2

I'm running out of disk, but don't know what is using it up. DiskUsageAnalyzer can't see the problem either.

More Details:

df shows the disk getting full

$ df -k /
Filesystem     1K-blocks      Used Available Use% Mounted on
/dev/sda2      483429920 447182672  11667308  98% /

but du shows only 68.9 G used (far less than the 447G shown by df.)

$ sudo du -sk /
du: cannot access '/run/user/1000/gvfs': Permission denied
du: cannot access '/proc/12251/task/12251/fd/3': No such file or directory
du: cannot access '/proc/12251/task/12251/fdinfo/3': No such file or directory
du: cannot access '/proc/12251/fd/4': No such file or directory
du: cannot access '/proc/12251/fdinfo/4': No such file or directory
68915724    /

The same thing can be seen in Disk Usage Analyzer (sudo baobab). When started, it shows a near full filesystem that I can select for analysis

 `filesystem root / 43.8 GB available 495 GB total

but clicking on that filesystem to analyze usage shows that / uses only 57.1 GB. and leaves me stuck trying to figure out how to clear my disk space

How can I find out what is using the space if I can't trust baobab or du to find it?

System details:

$ uname -s -r -v 
Linux 4.15.0-34-generic #37-Ubuntu SMP Mon Aug 27 15:21:48 UTC 2018
$ lsb_release -a
LSB Version:    core-9.20170808ubuntu1-noarch:security-9.20170808ubuntu1-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:    18.04
Codename:   bionic
  • Glad you solved the problem as noted in answer below. Next time though can you use df -h (h is for human) to make it easier to read? – WinEunuuchs2Unix Oct 15 '18 at 0:03
1

The answer seems to be related to https://serverfault.com/questions/315181/df-says-disk-is-full-but-it-is-not.

I had a very large Xorg log file that I had to delete. After the delete, the difference between df and du arose.

Reboot reaped the space and solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.