1

Boot manager problems, an eternal classic.

I'm here with my new HP Pavilion 14-bf110NS. It had Windows10 pre-installed. I installed Ubuntu 18 too. After that, it loads directly to Win. In the BIOS's UEFI Boot order, the first option is Windows Boot Manager and second one ubuntu. I moved ubuntu up. Then it starts with a blank screen for maybe a minute and then loads ubuntu. So, no menu to choose SO whatever the order of the UEFI Boot order.

In this laptop you still have the option to press Esc while is starting and then it gives you the option to select SO or open the BIOS configuration. If you do that and select ubuntu, then you see grub and you need to select ubuntu again. I'd love to press the power button and see grub from the start. Anyone knows?

I've been trying some solutions. One of them recommends disable the fast load in windows. I can't find that option where they say it should be. The powercfg /h off didn't worked neither.

  • Try using -h instead of /h in the powercfg command. For Nvidia hardware, you will need to add the word "nomodeset" to the grub line starting with linux at the "quiet splash" words, then add the proprietary Nvidia drivers (search this site, many instructions on this). HP used to need a special name for the bootloader, but that may no longer be necessary (again search this site). – ubfan1 Oct 14 '18 at 18:20
  • It's Fast Boot that needs to be disabled in your BIOS/UEFI. This should be seen as an option normally under the UEFI Boot options. Fast StartUp is a Windows configuration, and has nothing to do with Fast Boot. – Paul Benson Oct 14 '18 at 20:06
  • Thanks for clarification, Paul. Unfortunately, I combed the BIOS Setup and there's no Fast Boot option there. – Miguel Angel Fas Oct 15 '18 at 22:31
  • @ubfan1 I felt curious about the option prefix because /h doesn’t print any error, nor -h. So I went to the command man page and it says at the begining –in a kind of index– that the option can be /hibernate or /H,. Later on, when it describes the option, says that the option can be /hibernate or /h. To play safe I tried /hibernate. Anyway powercfg [/H|/h|/hibernate|-h] off, all of them print the same: nothing. Exactly as the result of applying it on the boot loader issue. But I searched about your second suggestion, and it worked! Thanks a lot. – Miguel Angel Fas Oct 16 '18 at 0:20
0

@ubfan1 put me on the track: I let the steps here in case anybody needs them. Edited sudo nano /etc/default/grub and set GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet splash". Then updated grub: sudo update-grub. In the BIOS Setup, in UEFI Boot Order > OS boot manager, Ubuntu must be first one. The reasons behind those options are explained here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.