1

I've recently started using Ubuntu 18.04 and I am facing a very obnoxious problem - there's no way of changing the keyboard layout with ANY keyboard shortcuts, system-wide, not just in a certain program.

At first I thought that my standard shortcut (super+space) was interfering with some other shortcut containing super, but alt+shift or ctrl + shift do not function either. However, I am able to change the layout using the tray icon and the setxkbmap command in the terminal. I have tried to set shortcuts manually through the custom shortcuts menu, using the same setxkbmap command - no dice. I've also attempted to reconfigure the keyboard through the terminal, still no effect. Changing settings in GNOME tweaks doesn't help.

I would really like to evade any kind of reinstallations and such. If this matters in any way - I am using Unity.

1

Apparently, the problem was that I was using Unity. I changed my desktop environment to GNOME, checked the keyboard shortcut settings and found them off. After changing them back to normal and returning to Unity the issue was fixed.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.