2

I was upgrading my laptop from 16.04 to 18.04 using the do-release-upgrade command.

It downloaded everything and went about unpackaging things and installing them.

I was doing this in a virtual terminal (Ctrl-Alt-F6) and I had two graphical terminals open at the same time (F7 and F8).

The update froze—and I couldn't open any applications in either of my graphical terminals. The applications that were already open (Nautilus and Solitaire) worked fine, but nothing else. Switching to any other virtual terminal showed the same as F6, just a frozen update in progress with all the output there.

After attempting to get another shell (I couldn't), attempting to kill or suspend the update (I couldn't), open up Terminal in one of my GUI terminals (I couldn't), or just reboot or shut down from the GUI terminal (I couldn't), I held down the power button until the computer shut off, and started it up.

I got the Ubuntu splash screen, and a mouse that moves when I use the trackpad. Black screen otherwise. This is on terminal 7; switching to terminal 6 I get a text login prompt and can log in. /etc/os-release shows I have 18.04, but I don't have internet (of course) and running startx doesn't have any effect.

Also, the text that appears after I log in says "Welcome to Ubuntu 18.04.1 LTS" but goes on to say my Hardware Enablement Stack (HWE) is going out of support on 2023-04-30, and suggests I:

* Upgrade from Ubuntu 16.04 LTS to Ubuntu 18.04 LTS by running:
sudo do-release-upgrade -p

OR

* Switch to the current security-supported stack by running:
sudo apt-get install libwayland-egl1-mesa-hwe-18.04 xserver-xorg-hwe-18.04 linux-generic-hwe-18.04

and reboot your system.

I tried rebooting, and there was no change.

How can I get X working again and get a graphical login back? (Note: I usually use WiFi, but I do have an hard line and an Ethernet cable available if that would make things easier.)

(P.S.: I'm not sure what tags are relevant, so I only put a couple.)

2

I found this answer, and I tried

sudo apt-get install xorg

And I got:

E: dpkg was interrupted, you must manually run
 'sudo dpkg --configure -a' to correct the problem.

Running that, I got a whole bunch of Setting up (such and so package), and then, after a LONG while, it all finished.

I rebooted and now it's working! (WiFi still isn't, but that's a separate issue I think/hope.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.