6

I just install Ubuntu 18.04 yesterday, and it seems like Ubuntu cannot detect wifi adapter. The card is working on Windows, so it should not be a problem. I also have the same firmware as the one stated on Intel website (iwlwifi-9260-th-a0-jf-a0-34.ucode). Checking the log, I see iwlwifi failed with error -110.

Any idea how to troubleshoot this issue?

Thanks,

Below is the details log:

$ lspci | grep Network
03:00.0 Network controller: Intel Corporation Device 2526 (rev 29)

$ dmesg | grep iwlwifi
[    2.536811] iwlwifi 0000:03:00.0: enabling device (0000 -> 0002)
[    2.570596] iwlwifi: probe of 0000:03:00.0 failed with error -110
[  382.228750] iwlwifi: probe of 0000:03:00.0 failed with error -110

$ iwconfig
lo        no wireless extensions.
eno1      no wireless extensions.

$ modinfo iwlwifi
filename:       /lib/modules/4.15.0-29-generic/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
license:        GPL
author:         Copyright(c) 2003- 2015 Intel Corporation <linuxwifi@intel.com>
description:    Intel(R) Wireless WiFi driver for Linux
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-6.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-6.ucode
firmware:       iwlwifi-7265D-29.ucode
firmware:       iwlwifi-7265-17.ucode
firmware:       iwlwifi-3168-29.ucode
firmware:       iwlwifi-3160-17.ucode
firmware:       iwlwifi-7260-17.ucode
firmware:       iwlwifi-8265-34.ucode
firmware:       iwlwifi-8000C-34.ucode
firmware:       iwlwifi-9260-th-b0-jf-b0-34.ucode
firmware:       iwlwifi-9260-th-a0-jf-a0-34.ucode
firmware:       iwlwifi-9000-pu-a0-jf-b0-34.ucode
firmware:       iwlwifi-9000-pu-b0-jf-b0-34.ucode
firmware:       iwlwifi-9000-pu-a0-jf-a0-34.ucode
firmware:       iwlwifi-QuQnj-a0-hr-a0-34.ucode
firmware:       iwlwifi-QuQnj-a0-jf-b0-34.ucode
firmware:       iwlwifi-QuQnj-f0-hr-a0-34.ucode
firmware:       iwlwifi-Qu-a0-jf-b0-34.ucode
firmware:       iwlwifi-Qu-a0-hr-a0-34.ucode
srcversion:     6BA065AF04F0DFDB8D91DBF
depends:        cfg80211
retpoline:      Y
intree:         Y
name:           iwlwifi
vermagic:       4.15.0-29-generic SMP mod_unload 
signat:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm:           amsdu_size:amsdu size 0: 12K for multi Rx queue devices, 4K for other devices 1:4K 2:8K 3:12K (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           antenna_coupling:specify antenna coupling in dB (default: 0 dB) (int)
parm:           nvm_file:NVM file name (charp)
parm:           d0i3_disable:disable d0i3 functionality (default: Y) (bool)
parm:           lar_disable:disable LAR functionality (default: N) (bool)
parm:           uapsd_disable:disable U-APSD functionality bitmap 1: BSS 2: P2P Client (default: 3) (uint)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)
parm:           fw_monitor:firmware monitor - to debug FW (default: false - needs lots of memory) (bool)
parm:           d0i3_timeout:Timeout to D0i3 entry when idle (ms) (uint)
parm:           disable_11ac:Disable VHT capabilities (default: false) (bool)

UPDATE: I tried to update to kernel 4.18 which use newer firmware but got the same issue.

  • 1
    Hi! Welcome to AskUbuntu! Can you also include the output of iwconfig? Be careful to redact anything that may be traceable like ESSIDs or MAC addresses with Xs. Thanks! – tu-Reinstate Monica-dor duh Oct 13 '18 at 11:28
  • 1
    Thanks. I have updated the iwconfig output in the question. It shows no wireless extensions. – hgminh Oct 13 '18 at 12:21
  • Hey @hgminh did you manage to get it working? I am currently struggling with a laptop having the 9260 Intel card, and can't get it to work. What I've tried: 1. Standard 18.04 ubuntu 1. Reinstall linux-firmware 1. Copy Intel ucode drivers to /lib/firmware from here and the referenced newer drivers 1. Updated to 19.04 1. Tried the same 1. Currently I am going to try 16.04 to see if downgrading helps. If you got it to work, could you please point me in the righ direction? – Matyas Aug 10 '19 at 14:41
  • 2
    @Matyas Unfortunately, the only way I manage to make it work is to boot into Windows and then restart to Ubuntu. The issue is tracked here. It is not likely to be resolved anytime soon :( – hgminh Aug 13 '19 at 4:00
  • Thanks. will post this as an answer below, for visibility, so others come to a conclusion quicker. – Matyas Aug 13 '19 at 18:03
4

it is a problem with fast startup mode of windows. I think because in that mode window keep the wireless adapter for itself when shut down hence linux cannot detect. Just go into setting > power & sleep > choose what power option do > shut down setting > uncheck the turn on fast startup > save change and it will work

2

iwlwifi-9260-th-b0-jf-b0-34.ucode is included in the package linux-firmware in Ubuntu Bionic.

Try upgrading or reinstalling the package.

apt-get --reinstall install linux-firmware

Don't try to manually install from an archive provided by Intel. Always try to find a package that provides the driver if possible.

  • 1
    Thanks. But after I reinstall firmware, the issue stays the same. I also tried to update kernel to 4.18 which use newer firmware (iwlwifi-9260-th-b0-jf-b0-38.ucode), but got the same result. – hgminh Oct 13 '18 at 13:20
  • 2
  • 1
    Thanks, it is also reported at bugzilla. – hgminh Oct 14 '18 at 8:39
2

The Intel 9260-AC Wireless Chipset doesn't work in newer Linux kernels (ex: Ubuntu 18.04).

Here is the kernel bugreport that can be checked for the status.

In my case this was affecting a freshly bought: Lenovo IdeaPad/Yoga S730.

The solution for me was to install Ubuntu 16.04 with an older kernel, which worked without any issue

-1

I just want to reach back in time from up here in THE DISTANT FUTURE, Jan 2020, and say I had the same problem with an Asus Zenith Extreme Alpha motherboard with the Wireless-AC 9260 not being recognized by Ubuntu 18.04.

I tried downgrading to 16.04, to no avail. Also tried updating the firmware; nope.

But the wired Ethernet worked, and a simple dist-upgrade did the trick for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.