0
sudo apt-get install libpython3.6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpython3.6 : Depends: libpython3.6-stdlib (= 3.6.6-1~18.04) but 3.6.6-1+xenial1 is to be installed
E: Unable to correct problems, you have held broken packages.

libpython3.6:
  Installed: (none)
  Candidate: 3.6.6-1~18.04
  Version table:
     3.6.6-1~18.04 500
        500 http://bd.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
     3.6.5-3 500
        500 http://bd.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

libpython3.6-stdlib: Installed: 3.6.6-1+xenial1 Candidate: 3.6.6-1+xenial1 Version table: *** 3.6.6-1+xenial1 100 100 /var/lib/dpkg/status 3.6.6-1~18.04 500 500 http://bd.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages 3.6.5-3 500 500 http://bd.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

  • sounds like you're using PPAs that're breaking things. Where're you getting the Python 3.6 packages from? – Thomas Ward Oct 12 '18 at 20:51
  • i am getting this after updating to 18.04.1 lts ubunu @ThomasWard – zellu rakib Oct 12 '18 at 20:53
  • Show me your apt-cache policy libpython3.6 output as an edit to your quesiton. – Thomas Ward Oct 12 '18 at 20:54
  • @ThomasWard thats the output – zellu rakib Oct 12 '18 at 20:57
  • can you also include apt-cache policy libpython3.6-stdlib as well, but this time don't erase the other content in your question and just add it as an additional bit of information at the bottom? – Thomas Ward Oct 12 '18 at 21:00
0

You have conflict between this two libpython3.6-stdlib versions: 3.6.6-1~18.04, 3.6.6-1+xenial1. Try to install libpython3.6-stdlib. It's possible that apt will offer you to remove this version: 3.6.6-1+xenial1

  • but installing it shows me it's already install in newer version. then how to remove 3.6.6xenial1 – zellu rakib Oct 12 '18 at 22:23
  • Try to remove 3.6.6-1+xenial1 and install new version: sudo apt-get remove libpython3.6-stdlib && sudo apt-get install libpython3.6 – metallic Oct 12 '18 at 22:37

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.